Live CD did not prevent an error-> bad mount containing space

Asked by (4M)Stephen on 2007-04-13

I Already have ntfs-config installed and it works. I have 2 windows drives, one is mounted as /media/Media which I can use, the other is the windows xp operating system mounted at /media/Windows
The problem is when I installed ubuntu I told it to mount as /Windows XP/ as a result it mounts as /Windows/ and does not show any files...

I tried unmounting the windows drive and renaming it in the device manager with no luck. Any suggestions? Easy fix? I frankly love the terminal so bring on the commands if it can be done that way.

thanks in advance!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
(4M)Stephen
Solved:
2007-04-14
Last query:
2007-04-14
Last reply:
2007-04-14
Ralph Janke (txwikinger) said : #1

Thanks for the question.

Could you please paste the contents of your /etc/fstab file?

Thanks.

(4M)Stephen (sasimon19) said : #2

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sdb3 :
UUID=b804ccdf-49fb-4ab4-907d-eb8b47535678 / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/sdb2 :
UUID=F130118E17F875C2 /media/Media ntfs-3g defaults,locale=en_US.UTF-8 0 1
# Entry for /dev/sda1 :
UUID=BCE0FDDBE0FD9C38 /media/Windows XP ntfs 0 0
# Entry for /dev/sdb1 :
UUID=2a1dc130-a132-44ab-a42c-53193f137a86 none swap sw 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdc /media/cdrom1 udf,iso9660 user,noauto 0 0
#Added by diskmounter utility
/dev/sdg1 /media/sdg1 vfat rw,user,fmask=0111,dmask=0000 0 0

(4M)Stephen (sasimon19) said : #3

So I figured out from that much to change this:

# Entry for /dev/sda1 :
UUID=BCE0FDDBE0FD9C38 /media/Windows XP ntfs 0 0

to

# Entry for /dev/sda1 :
UUID=BCE0FDDBE0FD9C38 /media/Windows ntfs 0 0

is there some kind of refresh from there? how do I get it to work right?

I tried this:
stephen@fanthia:~$ sudo mount -a
fusermount: mountpoint is not empty
fusermount: if you are sure this is safe, use the 'nonempty' mount option
FUSE mount point creation error: No such file or directory
Unmounting /dev/disk/by-uuid/F130118E17F875C2 (Media)
mount: wrong fs type, bad option, bad superblock on /dev/disk/by-uuid/BCE0FDDBE0FD9C38,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

so what now? reboot xserver?

John Haitas (jhaitas) said : #4

the reason it is mounting as /Windows/ rather than /Windows XP/ is because of that space you have there - try removing it...

try changing

UUID=BCE0FDDBE0FD9C38 /media/Windows XP ntfs 0 0

to

UUID=BCE0FDDBE0FD9C38 /media/WindowsXP ntfs-3g defaults,locale=en_US.UTF-8 0 1

to remount all your drives issue this command in your terminal

sudo mount -a

try that and let us know how it goes

Best (4M)Stephen (sasimon19) said : #5

Good show... it worked, thank you for the help!