wont login after resolution change

Asked by ChrisGreenwood on 2007-03-23

I installed Ubuntu just fine, but then I changed the max resolution using "sudo dpkg-recongifure -phigh xserver-xorg". After I rebooted I tried to login and the screen went blank then went back to the login screen. I know my password was right or it would tell me incorrect. I reinstalled Ubunutu and everything worked fine until I tried to up the resolution. The max was only 800x600 and I know my monitor can handle much higher than that (I'm at 1280x960 in windows). I even tried to undo the resolution changes by only selecting 800x600 and lower, but it didn't save the changes no matter how many times I tried. Also, if I used to command line interface I could login just fine. I can even get into X from the command line but not if I'm logged into my user name (it says not authorized to run X server).

Any help would be appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
ChrisGreenwood
Solved:
2007-03-26
Last query:
2007-03-26
Last reply:
2007-03-26
Carles Oriol (carlesoriol) said : #1

After changes to xorg.conf (/etc/X11/xorg.conf) edited with dpkg-reconfigure or manualy you can restart xserver using:

sudo /etc/init.d/gdm restart

Carles Oriol (carlesoriol) said : #2

You can easily edit with:

sudo nano /etc/X11/xorg.conf

What video card do you have?
What make/model of screen do you have?
It's possible that Ubuntu has incorrectly detected it. When you run dpkg-reconfigure xserver-xorg, what video card do you choose?
This problem can also happen if the refresh rate is set too high.

ChrisGreenwood (greenw40) said : #4

My video card is nvidea Gforce4 MX. My screen is a 17' Dell LCD only about a year and a half old. When I run dpkg-reconfigure xserver-xorg I keep the default video card.

Carles Oriol (carlesoriol) said : #5

Are you using propietary or free driver?

Best ChrisGreenwood (greenw40) said : #6

I got it, I still couldnt log into X with my name but I reinstalled, found nvidia restricted driver info, and installed the proper drivers. After this the correct resolutions were selectable in the admin menu. I just didnt use dpkg-reconfigure xserver-xorg because it messed everything up.