2nd HD in Sys. Manager but it's mounted a floppy!?

Asked by Robo116 on 2007-02-15

 The files on my currnet slave drive were originally written on a HD via Windows XP (NTFS format). I installed Ubuntu on a formatted HD (my primary), and have my other HD as my secondary. It seems that ubuntu knows it's a HD. It shows up as "IDE SLAVE" -> "WDC-WD800JB-00FMA0" -> "Volume NTFS." But under my computer instead of it showing an icon for my second HD I have another floppy icon!? Seriously, I have File System, Floppy Drive (real one), & Floppy 1 (supposed to be my slave HD). Also shows my "Floppy 1" drive as having 60.9GB of free space. Nice floppy drive huh?
     I don't think I forced XP to lock the files so they can't be accessed if outside of the original XP environment. But even if I did, I should still be able to see all the files, maybe not open or modify them all though.
     *Why can't I read/write/format my secondary HD that was originally created on XP?* Does ubuntu is a special HD format that isn't common?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
Robo116
Solved:
2007-02-21
Last query:
2007-02-21
Last reply:
2007-02-21
williamts99 (williamts99) said : #1

What version of Ubuntu are you using? Also have you tried to format using the Gnome Partition Editor gparted?

Robo116 (robo161) said : #2

     I am using the newest version of Ubuntu Version 6.10 I believe. I actually installed Ubuntu fresh last week on my primary HD. It's been a while since I have used it on my server, so I thought I would give it another try.
     No, I have not tried Gnome Partition Editor. How does it work and what will it do for me? Also, will Ubuntu recognize a Windows XP formatted (NTFS) hd or is that why im having a problem with my slave drive?

Thanks,
Steve

Benoit Malet (benoit-malet) said : #3

Hello !

Ubuntu can read NTFS partitions without problems, but it can't write on it (unless you enable experimental write support in kernel, but it's NOT recommended)

It might be a problem in the fstab file ... Can you copy/paste the output of "cat /etc/fstab" (without quotes) here, so we can have a more precise view of your system ?

Thanks,
Benoît

Robo116 (robo161) said : #4

Here is the cat /etc/fstab output:

robo116@ubuntu:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda1
UUID=843533db-93a6-4dbd-8662-e37750980c64 / ext3 defaults,errors=remount-ro 0 1
# /dev/hda5
UUID=c87d68a1-f334-4baf-9a63-c6daa8d14c6e none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/ /media/floppy0 auto rw,user,noauto 0 0
robo116@ubuntu:~$

Benoit Malet (benoit-malet) said : #5

OK, so the problem comes from this file ;) ... If you have a look, you'll see that there is no mention of your second disk ...

You should :

- determine which drive is your NTFS disk (/dev/hdb ?) ... There are several ways to do this, if you have no idea, just ask (or google ;))
- create a directory in which you plan to mount your NTFS drive (for example /mnt/data)
- add a line in /etc/fstab (which will look like /dev/hdb /mnt/data ntfs defaults,ro,gid=46 0 0) as superuser

If you need information on how to proceed with these steps, don't hesitate ! I think we're getting close to solution ;)

Regards,
Benoît

Robo116 (robo161) said : #6

Well I am sure that my slave drive is considered hdb because that's how the BIOS sees that HD and when I installed Ubuntu it allowed to to choose which HD to install to and I chose hda (hdb was also on there). Ok, I followed your instructions as closely as possible...I hope.
1) Created a folder within /mnt and called it data
2) Logged in as root and added this line:
     "/dev/hdb /mnt/data ntfs defaults,gid=46 0 0" and saved it
3) Wasn't sure if something magical was supposed to happen ;) so I tried some random commands in the terminal (no expert in linux cmds). Tried "mount /dev/hdb" and it says "Wrong fs type, bad option, bad superblock on /dev/hdb, missing codepage or other error. In some cases useful info is found in syslog - try dmesg | tail or so."
     Should it automatically show up in "Computer" with the other drives or should I have to mount it manually like I was trying in the terminal? I got this far could you please guide me the rest of the way so I can access this HD?
     PS: If the BIOS and even Ubuntu knows that there is a hdb within the system why doesn't it try to mount it automatically? Or did it try to mount it automatically and thats why I have that 60GB floppy 1? I just figured Ubuntu would take care of most of this stuff by itself.

Benoit Malet (benoit-malet) said : #7

Hello !

If everything is OK, you should find the content of your HD in the directory /mnt/data (after a reboot, as /etc/fstab is used at boot time)

If it's not OK yet, just post the problem here and I (or another) will have a look ;)

Regards,
Benoît

Robo116 (robo161) said : #8

Hey Benoit Malet (again) :)

     Well everything is pretty much the same, actually its exactly the same. I looked in /mnt/data and there was nothing (even checked for hidden files/folders). I know for sure I have stuff on hdb, and once it says ~60GB free and its a 80GB hd I have around 20GB of misc. files on there. I wasn't sure what other info you might need but here is my fstab file again.

root@ubuntu:~# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda1
UUID=843533db-93a6-4dbd-8662-e37750980c64 / ext3 defaults,errors=remount-ro 0 1
# /dev/hda5
UUID=c87d68a1-f334-4baf-9a63-c6daa8d14c6e none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/ /media/floppy0 auto rw,user,noauto 0 0
/dev/hdb /mnt/data ntfs defaults,gid=46 0 0
root@ubuntu:~#

I'm out of ideas, I hope you have one :)

Benoit Malet (benoit-malet) said : #9

Hello (again ;)),

In fact, I actually have an idea ;)

You should try to edit fstab once more and replace /dev/hdb with /dev/hdb1 ... After a reboot, I think that should do ... Otherwise, try to open gparted if installed or use "fdisk /dev/hdb" (with caution) to verify the ID for your NTFS partition.

Hope this will solve the problem ;)

Regards,
Benoît

Best Robo116 (robo161) said : #10

hey, we finally got it to work (well u did anyway)! Yeah I just had to change my fstab to /dev/hdb1 and save it. It actually makes sense that it needs a number after hdb, considering the rest of the fstab command lines. I also didn't even bother rebooting, I just had to "mount /dev/hdb1" and then my files appeared in the data folder.

Thanks for you help,
and maybe someday I will move up from a Linux newb ;).

Thanks again,
Steve

Brand0n (bboltonlewis) said : #11

thanks, but i solved it myself!

Brand0n (bboltonlewis) said : #12

sorry, wrong thread! ;)