my usb wireless mouse is not being recognized

Asked by youronlygod on 2007-02-14

I am trying to install the drivers for my wireless usb mouse, I have never used a Linux based system before and am not familiar with the Ubuntu device manager. I know that in windows I could just right click the device and update/install the driver but that does not seem to be an option with Ubuntu.

Can anyone offer simple step by step instruction for a newbie?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
youronlygod
Solved:
2007-02-26
Last query:
2007-02-26
Last reply:
2007-02-22
Benoit Malet (benoit-malet) said : #1

Hello,

Could you please give some information on which type of mouse it is (brand, model, ...) ?

What happens if you just plug it ? And after a reboot ?

Regards,
Benoît

Ralph Janke (txwikinger) said : #2

Was the mouse plugged-in when you installed ubuntu?

williamts99 (williamts99) said : #3

also, what is the output of the command

lsusb

that is LSUSB in lowercase.

youronlygod (youronlygod) said : #4

it is a Targus model # AMW15US

the mouse recognized it is connected to a powered USB port but the system gives no reaction whatsoever even after a reboot

no it was not plugged in when I installed the OS

I don't know what 'the output of the command' means so I don't know how to answer that question, bear in mind I have never used a command based os before and just installed this about one week ago. If you can explain what that means and how to check it I will be happy to do so and provide that info.

Benoit Malet (benoit-malet) said : #5

Hello !

To give the output of the command lsusb, just open a console (terminal) and at the prompt type "lsusb" (without the quotes), followed by Enter ... It should give you a bunch of information that you can copy/paste here, so we can try to diagnose the problem ;)

I guess it's already done (maybe you use this mouse in Windows), but double check that USB support is activated in BIOS.

You can also try to type this command (in terminal, you should find one in start menu) : cat /dev/input/mouse0
If it outputs something on your screen, just tell it here ;) ...

If it doesn't work, you can try with cat /dev/input/mice

Have a nice day !
Benoît

youronlygod (youronlygod) said : #6

Bus 003 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000

that was the result of the command lsusb

cat: /dev/input/mouse0: Permission denied

that was the result of the command cat /dev/input/mouse0

I may be new to this os but correct me if I am wrong I don't want it to say permission denied, right?

Thanks for all the help thus far,
  ~V

Dave Walker (davewalker) said : #7

Hi,

Using the Terminal again; Applications -> Accessories -> Terminal

copy and paste:
ls /dev/input/mouse*

This will show us what mice Ubuntu has recognised.

It appears that this mouse is supported 'out of the box' but for some reason it hasn't. Can i ask you to try a different USB port and (if still installed) try it under Windows, just to confirm the device hasn't malfunctioned.

youronlygod (youronlygod) said : #8

/dev/input/mouse0 /dev/input/mouse1 /dev/input/mouse2

the above is the result of the command ls /dev/input/mouse*

I have tried all USB ports

I do not still have windows installed on this pc but I can try the device w/another pc and let you know on that one, but it was working on this pc w/windows xp media edition installed prior to the change to Ubuntu.

Thanks again for all the support on this!
~V

Benoit Malet (benoit-malet) said : #9

Hello !

When you have a problem with permissions, you can prefix the command with "sudo", which means you want to run the command as privileged user ... sudo ask for your password before doing anything ...

Maybe you could retry my suggestion with sudo ;)

When you have tried your hardware on another computer, just tell us too ;)

Regards,
Benoît

youronlygod (youronlygod) said : #10

I have tried the mouse on another pc and it works fine with the windows pc (xp home edition)

so for this sudo I just retry which command with sudo in front of it? lsusb or cat /dev/input/mouse0 ?

Benoit Malet (benoit-malet) said : #11

Hello !

I tried on my Ubuntu, just issue this in a terminal:
sudo cat /dev/input/mouse0
(it asks for your password)

Move your mouse around and you should see strange stuff on your screen ... If not, try with /dev/input/mice.

Please tell here if it works ;)

Regards,
Benoît

youronlygod (youronlygod) said : #12

youronlygod@youronlygod-laptop:~$ /dev/input/mice
bash: /dev/input/mice: Permission denied
youronlygod@youronlygod-laptop:~$ sudo /dev/input/mice
sudo: /dev/input/mice: command not found
youronlygod@youronlygod-laptop:~$

youronlygod@youronlygod-laptop:~$ sudo cat dev/input/mouse0
cat: dev/input/mouse0: No such file or directory

there are the results
although the first time I did the sudo cat dev/input/mouse0 one it did ask for the password then I typed it and it did not show the letters, assumably b/c it is a password, then hit enter and nothing happened so I tried to move the mouse and nothing happened still.
What I pasted above for that command was the result of the second attempt.

Benoit Malet (benoit-malet) said : #13

Hello !

As it was not succesful, maybe you can try with these and report which gives output when moving mouse :

sudo cat /dev/input/mouse1
sudo cat /dev/input/mouse2

If your mouse is out there, we'll find it ! (and make it so you can use it !)

Regards,
Benoît

youronlygod (youronlygod) said : #14

neither command gave output
I entered the command pressed enter
gave my password and pressed enter and nothing happened
so I tried moving the mouse still nothing happened

Benoit Malet (benoit-malet) said : #15

Hello !

Except for trying a new install with your mouse connected, I can't see new possibilities anymore ...

Sorry, but my ability to help ends here, hope you'll find more knowledgeable people to help with this problem ...

Regards,
Benoît

youronlygod (youronlygod) said : #16

Thanks again for all your help that is the conclusion I came to as well but I really appreciate your assist in the matter.

thank you again,
~V

Best youronlygod (youronlygod) said : #17

I am closing this support request and will simply try another mouse, thanks to all!

I was having trouble with a Logitech USB mouse not being recognized, until I stuck the USB receiver into a different USB port. Now the mouse works, but the commands above (sudo cat /dev/input/mouse<#>; jiggle mouse) do not work. However, when the mouse started working I did find three new devices in /dev:

ccie5000@mercury:~$ ls -lt /dev
crw-rw---- 1 root root 253, 4 2009-01-08 19:00 usbdev1.40_ep81
crw-rw---- 1 root root 253, 5 2009-01-08 19:00 usbdev1.40_ep00
crw-rw---- 1 root root 251, 0 2009-01-08 19:00 hidraw0

The command "sudo cat /dev/hidraw0" followed by mouse jiggling now *does* show garbage characters, indicating the mouse is working:

ccie5000@mercury:~$ sudo cat /dev/hidraw0
 
         ������
                       ���������������������������������^C

I'd suggest:

1. Try inserting the USB receiver stick into different USB ports. Maybe, like me, you'll find you have been trying to use a bad USB port.

2. Insert the USB receiver stick into a USB port, then do a "most recent first" (-t) listing of the /dev directory:

        ls -lt /dev | head -20

Good luck,
Jerry

--
Jerry J. Anderson, Member Home Office: 720.887.5798
Anderson Consulting, LLC Mobile: 773.793.7717
800 Ridgeview Ave
Broomfield, CO 80020-6618 mailto:<email address hidden>
http://www.linkedin.com/in/AndersonConsultingLLC

Niklas Larsson (unixinfo) said : #19

I have the same problem. The external wireless mouse won't work. I tried everything. Your operating system can fly to the moon but it can't support the most basic hardware.