Preinstalled Lenovo Thinkpad R61i - no wifi after a few minutes when first received

Asked by Alex Cockell on 2008-05-15

I am using a Thinkpad R61i preinstalled with Ubuntu 8.04. Purchased from Linux Emporium (UK).

While it runs on wired Ethernet quite happily, the Wifi light is not on - and there is no sign of the Wifi symbol in the top right of the Gnome UI (I use and support XP and Lotus Notes at work, an am relatively new to Linux - although I am comfy with package managers as we use that method at work).

The Wifi interface seemed ot be on during the initial phase, but as soon as I applied the Ubuntu-restricted package (MP3 etc), and Adobe Flash 9 (both via Synaptic), the wifi interface has refused to work.

Being new to the operating system, and seeing that I bought this laptop preinstalled - I have no idea of the wifi chipset - all I know is I am currently having to use the machine wired.

I have taken a look - and it would appear that I use an Intel i3945 - from the bugs reported.

Is it likely to be fixed in the near future, so I can just pick up the fix through a critical systems update, as I would not feel comfortable upgrading?

I have already reported the problem to my vendor.

All I want is to be able to use Wifi out of the box with my router - and then be able to connect seamlessly.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
Alex Cockell
Solved:
2008-05-18
Last query:
2008-05-18
Last reply:
2008-05-18
Alex Cockell (alcockell) said : #1

Re the source package entry - I have *absolutely no idea* where in the entire OS the problem is. Please could whoever assists or raises this problem with the OS development team deal accordingly.

Thanks in advance.

IIRC, Linux Emporium promises things like wifi to work out of the box...
First things first, I would inform them of their lack of due-diligence.
You can run this command in a terminal and post the output here- best to copy/paste given your lack of familiarity with the OS...
lspci
this will tell us your chipset and get the ball rolling on a solution.

By all means, let LE know you're not thrilled with the prospect of getting this resolved on your own.
There's no reason at all they should leave this up to you to fix, you PAID them on the premise that they'd do the heavy lifting.
DS

Sorry, should have posted as "Needs Info"

Please follow the above step to get this fixed asap.
DS

Alex Cockell (alcockell) said : #4

Thanks for coming back..

Linux Emporium gave me the following advice in a README on the laptop itself when I logged in for the first time.

"2. Wireless should work fine. Set up is (in Gnome) via System->Administration->Networking and should be fairly obvious. If you have problems give us a ring.

If at any time wireless mysteriously stops working, there is a slider switch on the front left of the machine which must be slid to the right to work. You may find that you have accidentally switched it off (the switch facility is useful to save power when you don't need wireless, or when you're on an aircraft etc)."

I checked - it was.

You asked for the results of the command "lspci"

Results are...

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
04:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b6)

While I'm not exactly famliar or enamoured with diving under the bonnet, it will be a learning curve - but this IS my primary machine, and I was kinda expecting a rescue CD or DVD to come with it (OK - so I'm a Lotus Notes admin and 2nd line support in a locked down, package-managed XP environment at work - but seeing all the hassles people have with Vista - I was not going there).

Admittedly - I have *used* Linux for a while; was running a minimal out-of-the-box install of SuSE 8.0 Professional with absolutely no updates, no sound etc on an old Toshiba Satellite 230CX before buying this machine. But by no stretch of the imagination would I call myself a guru.

Then again - most of my sysadmin and environment-fixing has been done in a corporate IT environment, where we can always rebuild if nothing fixes the problem.

Thanks for any and all help... how *does* the bug-fix sequence carry on? Is it like us at work - where a new package replaces the old and I just collect the new ones with no risk to my machine?

I have holiday coming up, and I'll continue with them then.

Alex Cockell (alcockell) said : #5

Oh - my reply "I checked - it was." to Linux Emporium's comment should have been "I checked - it was switched on".

Bluetooth starts up happily - it's just the wireless services that don't appear to.

Extra point - on Network Manager (rightclick on the current LAN option in - umm - are the graphics in top right next to my system clock Linux's equivalent of the System Tray in Windows?), there didn't appear to be an option to force a WiFi scan.

Is that in as an enhancement, currently being worked on?

MattWelborn (mattwelborn) said : #6

Could you post the results of the command:
ifconfig

Alex Cockell (alcockell) said : #7

Thanks for coming back...

Umm - what gives?

alex@ubuntu:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:1e:37:cb:02:2d
          inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
          inet6 addr: fe80::21e:37ff:fecb:22d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:411325 errors:0 dropped:0 overruns:0 frame:0
          TX packets:311075 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:567796295 (541.4 MB) TX bytes:28936665 (27.5 MB)
          Interrupt:21

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:1494 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1494 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:75653 (73.8 KB) TX bytes:75653 (73.8 KB)

wlan0 Link encap:Ethernet HWaddr 00:1f:3c:1b:c1:0b
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wmaster0 Link encap:UNSPEC HWaddr 00-1F-3C-1B-C1-0B-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

alex@ubuntu:~$

IT would suggest appear that the interface is up... but if I pull the Ethernet cable out - Linux Emporium suggest I should see the wired Ethernet icon switch to the circular-swirling-thing.. but this only happens when I put the cable back.

I use a Netgear 834GT router - but I had been running with wifi switched off.. switched it back on again,, but hadn't rebooted as it appears to be transmitting on that interface...

Stats from router

System Up Time 756:14:51
Port Status TxPkts RxPkts Collisions Tx B/s Rx B/s Up Time
WAN PPPoA 3460084 4734561 0 106 697 756:13:45
LAN 10M/100M 4755184 3475938 0 730 130 756:14:49
WLAN 11M/54M 6813 0 0 4 0 143:08:45

ADSL Link Downstream Upstream
Connection Speed 8032 kbps 448 kbps
Line Attenuation 25.0 db 13.0 db
Noise Margin 17.1 db 28.0 db

Shouldn't my Connection Manager automatically find and present my router as a connection option within seconds?

Config is preinstalled 8.04 Ubuntu Linux - as installed by my vendor. The only thing I did do was go into System/Admin/Network, elevate rights, uncheck then immediately check Enable Roaming - and cancel out. Under XP, this would have not written anything back.

Does anyone have a scheduled date when Canonical will have fixed this problem?

Alex Cockell (alcockell) said : #8

I was wondering - would switching the wireless switch on the bottom left of the case off and on again force Linux to redetect and switch Wifi back on? OR will that cause the machine to crash?

MattWelborn (mattwelborn) said : #9

I doubt that switching the wireless would cause the system to crash, but at the same time, I doubt that it would help anything.

This probably won't work, but have you tried "sudo ifconfig wlan0"?.

Alex Cockell (alcockell) said : #10

Umm - before I do that - what are you expecting it to do?

Just that I'm scared of breaking this machine as I have only had it a week...

Alex Cockell (alcockell) said : #11

Umm - the way this machine was sold to me - surely I should just be able to select my router from a list of available wifi hotspots...

I'd rather not have to go to a command line and elevate my privileges just to connect dynamically.. which Linux Emporium said this machine could do.

Does anyone have a scheduled fix date from Canonical?

MattWelborn (mattwelborn) said : #12

Sorry for the ambiguity. "sudo ifconfig wlan0 up" tells the computer to turn the interface "wlan0" (wireless local area network 0) on. I don't think that there is much chance that it will work, but it certainly won't hurt anything (if it did, I would have broken my computer by now).

Alex Cockell (alcockell) said : #13

Did nothing... I rebooted my router, yanked my Ethernet cable, expected to see the double-display icon change to the swirling balls and then present me with a WiFi strength signal - nothing.
Rightclicked and unchecked "Enable wireless" - nothing.
Rechecked "Enable wireless" - nothing.
Reconnected Ethernet lead - swirly balls (one blue one green - turned both green - connected): I assume this is the machine picking up a DHCP address. Able to browse again.

Opened a command line window, tried "iwconfig wlan0 scan" - nothing was listed.

I believe I've called my home router "COCKE9CC"... shouldn't this appear on some kind of Connection Manager, then the machine prompts me for a WEP key (or not) - and I'm in?

Alex Cockell (alcockell) said : #14

I tried - as a leap in the dark, LEFT-clicking on my connection manager - and the update I had applied earlier nailed it...

THanks all - I now have my Wifi working..

Alex

Quentin Wright (q-clocksoft) said : #15

Hi Alex,

Unfortunately I've discovered this thread a little late in the day.

You said that you had reported the problem to us, but I can't find any trace of an e-mail from you asking for help. I do recollect having a brief phone conversation with an R61 purchaser about the switch, although I'm not sure whether it was yourself.

You will appreciate that Network Manager has only really become properly functional with the release of kernel 2.6.24 and even now there are some issues when the Access Point key is changed, consequently the README with the laptops recommends that you use the manual configuration option of Network Manager. You didn't say in the posting how far you got along with this.

From the output of ifconfig you had an address established with the eth0 interface - that's the hardwired ethernet
interface. When you have an address on that interface Network Manager won't manage the wireless interface.

Additional commands to use to assess the state of the interface are:
$ sudo iwconfig and
$ iwlist scanning.

iwlist scanning produces a list of available access points then that
confirms that you are in a position to go ahead and configure the
interface with Network Manager.

Some of the advice you were given was misleading - sudo ifconfig wlan0
up will not work if the interface is being managed by Network Manager.

Anyhow the steps to configure an interface with Network Manager are as
follows:

Right-click on the Network Manager icon – it looks like a pair of computer screens on the upper panel. If your wireless device has been detected there should be an Enable Wireless option. Click on this so that it becomes ticked.

If the Enable Wireless option isn't present, then you should left-click on the Network Manager icon and, select Manual Configuration, unlock the menu, select the Wireless Connection, select Properties and disable and re-enable roaming mode.

Then left-click on the icon and select the small button beside the network that you wish to connect to:

You should be prompted for a passphrase or key.

Enter a passphrase or key. The icon will change and if a connection is established the icon will change to a bar graph indicating the signal strength.

If the mouse pointer is hovered on the icon a legend will be displayed with a legend like "Wireless Network Connection to myaccesspoint (82%)".

Information about a connection can be obtained by right clicking on the Network Manager icon and selecting Connection Information.

Hardy Heron works very well with the Thinkpads and other Lenovo and most of the features now just work.

Quentin

Alex Cockell (alcockell) said : #16

Hi Quentin,

Um - I think that was me.

At the time - I must have still been thinking Win32 - system tray icons are always right-clicked when running XP - left-clicking them doesn't normally do much... had forgotten the XWindow way of doing things.

I emailed you as well.. thanks for coming back; I was very frustrated at the time...

On left-clicking Net Mgr... there was my router giving me a 93% signal..

Thanks again.. put this down to user error - muscle memory had me following the Windows method...