my system don't read my external drive

Asked by jose hernandez on 2008-05-09

i have a external driver where i keep my musci an pics and all that but my ubuntu system can't read the driver it gives me an error "cannot mount a volume" i don't know what to do help please

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Last query:
2008-05-09
Last reply:
2008-05-09
Lee Glidewell (lee-glidewell) said : #1

If you can answer a couple questions, someone may be able to help you better:

1) What kind of external drive? Are you connecting it with USB, Firewire, or eSATA?

2) Run the following in a terminal:

 sudo fdisk -l

What are the results of this command?

jose hernandez (amerjose81) said : #2

i have a wd external drive and how i run that command (SUDO FDISK -I)

Lee Glidewell (lee-glidewell) said : #3

Again, what type of connection does the external drive have? I'm assuming it's USB, but if you could doublecheck, that would help.

To run the command, go to your applications menu, and under "Accessories" you will find the "Terminal" application. Open this, and type the command:

 sudo fdisk -l

Please note that this command is case sensitive, so you should type it exactly that way (or it won't work). After you enter this, it will ask you for your password. Enter this, and it will return data about attached disk drives. You can copy and paste that data here.

jose hernandez (amerjose81) said : #4

Disk /dev/sda: 60.0 GB, 60022480896 bytes
255 heads, 63 sectors/track, 7297 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0000675f

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 7205 57874131 83 Linux
/dev/sda2 7206 7297 738990 5 Extended
/dev/sda5 7206 7297 738958+ 82 Linux swap / Solaris

Disk /dev/sdb: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x44fdfe06

   Device Boot Start End Blocks Id System
/dev/sdb1 1 38913 312568641 7 HPFS/NTFS
amerjose8

thats whta it says after i run that command and is connected to the usb

naufal (musp-student) said : #5

hello,
type in terminal:
sudo mkdir /mnt/disk
sudo mount /dev/sdb1 /mnt/disk

hope this help...

Lee Glidewell (lee-glidewell) said : #6

It looks like that disk is formatted as NTFS, which means that it will be necessary to modify the mount command:

 sudo mount -t ntfs /dev/sdb1 /mnt/disk

It's been a while since I've used an NTFS partition with Linux, so I'm not sure what progress has been made, but you may find that this disk does not support hotplugging in the way you would like. Solutions would include running the mount command manually, or formatting the disk to something more Linux-friendly (FAT32 is the usual choice for cross-platform compatibility).

Can you help with this problem?

Provide an answer of your own, or ask jose hernandez for more information if necessary.

To post a message you must log in.