How to install wintv-PVR-500MCE on Ubuntu 7.04 client, and MythTV - new user

Asked by Lonewolf23 on 2008-02-06

Hello, I am new to Ubuntu and want to set up my new WinTV-PVR-500MCE PCI card on Ubuntu 7.04 client.

I am fairly 'rookie' with linux in general and this is the first machine I have tried installing Ubuntu on (and trying to configure anything).

It sees the card in the device manager... I think under an unknown device and then multiple 'video device' sections. I have no idea how to find drivers for this card ... all of my searches seemed to fail on finding anything I could:
A. understand (mostly forums referencing other forums... )
and
B. the information for 7.04 of Ubuntu in general.

I intend to use MythTV for this Ubuntu media centre machine.

I really want to get away from relying on Windows in general... and am trying to learn Linux so that I can eventually build machines with it for parents and friends.

I do have a little Suse experience... but nothing with installing more than a NIC really.

This PVR has dual coaxial inputs as well as additional RCA inputs... I have no Media Centre Edition install to try it on and bought it do to the inputs and the hardware encoding. I hope that I haven't wasted the money (upgrading from my older winTV-go that doesn't like my digital cable signal at all...).

Any help on installing this device would be greatly appreciated. If it helps... the more I can learn the more I can convince my friends to have at least once Ubuntu machine going in their networks. Heh... I just need to figure out how to find drivers and applications.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
Allen Chemist
Solved:
2008-02-06
Last query:
2008-02-06
Last reply:
2008-02-06
Lonewolf23 (lonewolf23) said : #1

I found instructions on how to install MythTV through 'synaptic package manager' and it says that my PVR is supported by MythTV out of the box... I hope this means I don't need additional driver installation.

Best Allen Chemist (alchemist) said : #2

Hi Lonewolf,

While I don't have the wintv 500 (I have the 350), they appear to use the same driver (ivtv). When installing MythTV on my system, It Just Worked.

The best I can say is to try it, and make sure you run "mythtv-setup" once you are done installing "mythtv".

I also looked at what I have installed on my system, and in addition to the "mythtv" stuff (-backend, -frontend, -themes etc), I have the following:
ivtv-source
ivtv-utils
libvideo-ivtv-perl

These should be installed when you install mythtv. Once again, best to install mythtv, then check to see if these are installed.

Finally, what is the output of the following, done on the command line:
ls -l /dev/video*

Hope this helps
-Allen

Brandan E. Lloyd (brandan) said : #3

Lonewolf23,

This is just off the top of my head but I have set up mythtv at home a few times with Dapper and Gutsy with this same card and it is working. I'm pretty sure that the dual coax are actually one input and one for Fm the tuner (I haven't used this yet). When you connect your coax cable for the TV it is split internally on two tuners. You should be able to test to see if it is working by trying the following command 'mplayer /dev/video0'. This should play whatever is coming in on the cable.

Then you can install MythTV via synaptic or via the command line 'sudo aptitude install mythtv'. You can also install mythbuntu via synaptic or via the command line 'sudo aptitude install mythbuntu-desktop'.

Lonewolf23 (lonewolf23) said : #4

thank you both for your responses.

Looks like MythTV just works with it and detects it fine. No idea what the 'unknown device' is and why under it it shows multiple video device items... figured that was the tv card.

Now I just have to figure out if my media machine needs to be on the outside of my digital cable box... and/or how to record what i happen to be watching... i found a list of hotkeys for mythtv on wikipedia... so will see if there is a 'record now' option.

Thanks again

Lonewolf23 (lonewolf23) said : #5

Thanks Allen Chemist, that solved my question.

Lonewolf23 (lonewolf23) said : #6

thanks also to Brandan E. Lloyd.

i had origionally been using the 'add/remove' and not the synaptic package manager for installing