HAL support in Saucy?

Asked by Peter Lemieux on 2013-10-19

I notice that HAL is not available in 13.10 Saucy. Will this be released at some future date?

I realize that HAL is deprecated, but it is required if one wants to watch material from Amazon Instant Video. Without the hal and libhal1 packages, the Amazon player complains that the installed version of Flash Player is out of date. However once I installed those two packages in versions from 12.04 through 13.04, the videos played correctly. This is the solution that Amazon support recommends for Linux users.

I would prefer not to try and compile this from source if a package will be released in the coming weeks.

Question information

English Edit question
Ubuntu hal Edit question
No assignee Edit question
Solved by:
Peter Lemieux
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :


HAL has been out of Linux for a long time now.

Have you tried other web browsers to see if the same issue occurs? Have you reported a bug?

Revision history for this message
Peter Lemieux (seijisensei) said :

It doesn't work in Chromium or Firefox. I tried installing Chrome, but it is missing a dependency. I tried installing Chrome, but it has dependency problems even after installing libudev0 as suggested in http://www.omgchrome.com/install-google-chrome-in-ubuntu-13-10/.

"This isn't a bug, it's a feature." Installing hal and libhal1 is the only way I know of to enable Amazon Instant Video on Linux. As I said, it has to do with the methods they use to handle DRM. Maybe they will come up with another method in the future, but for the time being it is what it is.

It should be no surprise to learn that a service which targets Windows and Mac users, and which distributes DRM-encumbered videos, does not have good support for Linux. Using HAL is the one workaround that was available.

There are persistent discussions about this issue on Amazon's forums. A good example is http://www.amazon.com/forum/amazon%20video%20on%20demand/ref=cm_cd_fp_ef_tft_tp?_encoding=UTF8&cdForum=Fx3EQAX98ED5WQ3&cdThread=Tx167YET6CH0PQI.

Revision history for this message
Manfred Hampl (m-hampl) said :

According to https://bugs.launchpad.net/ubuntu/+source/squeeze/+bug/1221254/comments/23 there is a PPA with a package that re-enables the DRM handling for Amazon

Revision history for this message
Peter Lemieux (seijisensei) said :

Installing the "pipelight" browser plug-in for Linux solved this problem for me. After following the instructions at


I could watch movies at Amazon Instant once again without hal or libhal1 installed.