change USB mouse to normal mouse

Asked by Michael Harrison on 2008-01-23

I have successfully installed my first Ubuntu and used an available USB mouse for the purpose. No problems recognising any of the old hardware. I now need to change it for a normal mouse, to use keyboard, mouse and video sharing between 2 computers. If I just plug-in the new mouse it is not seen and can't find any options to "install new hardware". I am sure, given the completeness of the overall package, that this must be possible even for a beginner.

Question information

Bhavani Shankar (bhavi) said : #1

Hello

If you just plugin your other mouse i.e the normal mouse instead of USB mouse it should work if Ubuntu supports it.

try the following command in a terminal (applications ->accessories -> terminal) to see if its installed.

lspci

Bhavani Shankar.

Michael Harrison (mh-aabac) said : #2

Thank you Bhavani

Unfortunately, the system does not see it. I have tried 3 different mice
all of which work on a Windows box. I have tried powering up with just
the new mouse plugged in. It does not work but if I again plug in the
USB mouse it works fine.

The command gave information on host bridge, Pci bridge, ISA bridge, IDE
interface, USB controller, non-VGA unclassified device, VGA compatible
controller, multimedia audio controller and ethernet controller.

Michael

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Bhavani Shankar
Sent: 23 January 2008 14:21
To: <email address hidden>
Subject: Re: [Question #22887]: change USB mouse to normal mouse

Your question #22887 on hal in ubuntu changed:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

    Status: Open => Answered

Bhavani Shankar proposed the following answer:
Hello

If you just plugin your other mouse i.e the normal mouse instead of USB
mouse it should work if Ubuntu supports it.

try the following command in a terminal (applications ->accessories ->
terminal) to see if its installed.

lspci

Bhavani Shankar.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887/+c
onfirm?answer_id=0

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

You received this question notification because you are a direct
subscriber of the question.

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.516 / Virus Database: 269.19.9/1238 - Release Date:
22/01/2008 20:12

Bhavani Shankar (bhavi) said : #3

Hello sorry for the wrong command

its lshal..

and info about which version of ubuntu you are using?

Bhavani Shankar (bhavi) said : #4

Or if you are on ubuntu 7.10 and if you are using a PS/2 mouse:

Install the xserver-xorg-input-mouse package from the repositories

to do that type the following command:

sudo apt-get install xserver-xorg-input-mouse

in a terminal..

If its already installed there is no cause of worry

next up Try editing the "InputDevice" mouse section in your /etc/X11/xorg.conf file:

sudo gedit /etc/X11/xorg.conf

In the Input device section it should look like this:
Section "InputDevice"
...
        Driver "mouse"
        Option "Device" "/dev/input/mice"
...
EndSection

and maybe you also need to change the Protocol:

 Option "Protocol" "ImPS/2" # or "auto"

Hope that helps..

Michael Harrison (mh-aabac) said : #5

Hi Bhavani

I am using the latest version of Ubuntu with all automatic updates
installed (7.10?). The command lshal gave pages of info.. The 5th line
included "HID Mouse" I think this was associated with the USB ports.
What should I be looking for?

I have followed your instructions and changed "ExplorerPS/2" to "lmPS/2"
# or "auto" and I am afraid it makes no difference. "/dev/input/mice" is
as required.

I have also had an email with the following

    Linked to bug: #108382
    https://bugs.edge.launchpad.net/bugs/108382
    "ps2 mouse does not work in Feisty FINAL VERSION"

So perhaps, coincidentally it may not work anyway? Should I wait until
this bug is fixed?

A fundamental question from a newby - can I leave both the USB mouse and
PS2 mouse connected to try them or should I disconnect one or perhaps
reboot each time I try?

Thanks again

Michael

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Bhavani Shankar
Sent: 24 January 2008 06:29
To: <email address hidden>
Subject: RE: [Question #22887]: change USB mouse to normal mouse

Your question #22887 on hal in ubuntu changed:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

    Status: Needs information => Answered

Bhavani Shankar proposed the following answer:
Or if you are on ubuntu 7.10 and if you are using a PS/2 mouse:

Install the xserver-xorg-input-mouse package from the repositories

to do that type the following command:

sudo apt-get install xserver-xorg-input-mouse

in a terminal..

If its already installed there is no cause of worry

next up Try editing the "InputDevice" mouse section in your
/etc/X11/xorg.conf file:

sudo gedit /etc/X11/xorg.conf

In the Input device section it should look like this:
Section "InputDevice"
...
        Driver "mouse"
        Option "Device" "/dev/input/mice"
...
EndSection

and maybe you also need to change the Protocol:

 Option "Protocol" "ImPS/2" # or "auto"

Hope that helps..

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887/+c
onfirm?answer_id=3

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

You received this question notification because you are a direct
subscriber of the question.

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.516 / Virus Database: 269.19.10/1240 - Release Date:
23/01/2008 17:47

Bhavani Shankar (bhavi) said : #6

OK..try running reconfiguring xorg to use a ps/2 mouse

sudo dpkg-reconfigure -plow xserver-xorg

and keep us informed..

Bhavani Shankar.

Michael Harrison (mh-aabac) said : #7

Hi again!

Tried that

The first message I get is "fatal error inserting battery" !!!

Then it goes into a window to "attempt to autodetect video hardware". I
can then keep pressing "enter" through a number of pages as the <ok> is
highlighted. On the last page the <ok> is not highlighted and I cannot
press enter to continue. The page will scroll using buttons but not with
either (both connected) mouse. The last paragraph of this page starts
"When possible this question is pre-answered ......

I can exit the page by clicking on the "x" top rhs as normal.

Michael

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Bhavani Shankar
Sent: 24 January 2008 10:27
To: <email address hidden>
Subject: RE: [Question #22887]: change USB mouse to normal mouse

Your question #22887 on hal in ubuntu changed:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

    Status: Open => Answered

Bhavani Shankar proposed the following answer:
OK..try running reconfiguring xorg to use a ps/2 mouse

sudo dpkg-reconfigure -plow xserver-xorg

and keep us informed..

Bhavani Shankar.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887/+c
onfirm?answer_id=5

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

You received this question notification because you are a direct
subscriber of the question.

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.516 / Virus Database: 269.19.10/1240 - Release Date:
23/01/2008 17:47

Michael Harrison (mh-aabac) said : #8

Update

I may have mislead you on the previous email. <ok> is not highlighted
but there is a selection highlighted which is correct for my video
board. Except for the last page. Unfortunately I cannot re-run the
command at the moment because I get an error message

/var/cache/debconf/config.dat is locked by another process: resource
temporarilly unavailable.

Btw, it would be nice if, when entering the password in terminal, a *
character was echoed. I thought the keyboard was not responding. Hope
you don't mind me mentioning this.

Thank you

Michael

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Michael Harrison
Sent: 24 January 2008 10:51
To: <email address hidden>
Subject: RE: [Question #22887]: change USB mouse to normal mouse

Your question #22887 on hal in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/hal/+question/22887

    Status: Answered => Open

You are still having a problem:
Hi again!

Tried that

The first message I get is "fatal error inserting battery" !!!

Then it goes into a window to "attempt to autodetect video hardware". I
can then keep pressing "enter" through a number of pages as the <ok> is
highlighted. On the last page the <ok> is not highlighted and I cannot
press enter to continue. The page will scroll using buttons but not with
either (both connected) mouse. The last paragraph of this page starts
"When possible this question is pre-answered ......

I can exit the page by clicking on the "x" top rhs as normal.

Michael

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Bhavani Shankar
Sent: 24 January 2008 10:27
To: <email address hidden>
Subject: RE: [Question #22887]: change USB mouse to normal mouse

Your question #22887 on hal in ubuntu changed:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

    Status: Open => Answered

Bhavani Shankar proposed the following answer:
OK..try running reconfiguring xorg to use a ps/2 mouse

sudo dpkg-reconfigure -plow xserver-xorg

and keep us informed..

Bhavani Shankar.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887/+c
onfirm?answer_id=5

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

You received this question notification because you are a direct
subscriber of the question.

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.516 / Virus Database: 269.19.10/1240 - Release Date:
23/01/2008 17:47

You received this question notification because you are a direct
subscriber of the question.

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.516 / Virus Database: 269.19.10/1240 - Release Date:
23/01/2008 17:47

Bhavani Shankar (bhavi) said : #9

Ok..
Can you change the line in your xorg.conf from /dev/input/mice to /dev/psaux and try i.e

sudo gedit /etc/X11/xorg.conf

In the Input device section it should look like this:
Section "InputDevice"
...
        Driver "mouse"
        Option "Device" "/dev/psaux"
...
EndSection

and keep us informed...

Michael Harrison (mh-aabac) said : #10

Hi

Tried that but things are now worse. I rebooted bacause you did not say
if the changes take effect without rebooting and now, after the Ubuntu
scroll bar has completed the screen goes black. After a short while the
monitor flashes "out of range". I am running it on my Windows machine @
1024x768.

Perhaps my only option now is to re-install 7.10 and only have the PS/2
mouse plugged in. If you want me to do something else I am happy to try
it. Luckily my email is still on my windows box and there is nothing
important on the Ubuntu box (yet!!)!

Just to summarise,

Option "Protocol" "lmPS/2" # or "auto" (is the "I" in lmPS/2 an
upper case i or a lower case L? I used the latter)

Option "device" "/dev/psaux"

Are the changes made.

Michael

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Bhavani Shankar
Sent: 24 January 2008 12:05
To: <email address hidden>
Subject: RE: [Question #22887]: change USB mouse to normal mouse

Your question #22887 on hal in ubuntu changed:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

    Status: Open => Answered

Bhavani Shankar proposed the following answer:
Ok..
Can you change the line in your xorg.conf from /dev/input/mice to
/dev/psaux and try i.e

sudo gedit /etc/X11/xorg.conf

In the Input device section it should look like this:
Section "InputDevice"
...
        Driver "mouse"
        Option "Device" "/dev/psaux"
...
EndSection

and keep us informed...

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887/+c
onfirm?answer_id=8

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

You received this question notification because you are a direct
subscriber of the question.

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.516 / Virus Database: 269.19.10/1240 - Release Date:
23/01/2008 17:47

Michael Harrison (mh-aabac) said : #11

Hi

If it is any help, I have accessed the Ubuntu box through "remote desk
top" from my Windows machine. I remembered that my son had set this up
during the xmas holidays.

Would you like me to do anything else or shall I re-install?

Michael

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Bhavani Shankar
Sent: 24 January 2008 12:05
To: <email address hidden>
Subject: RE: [Question #22887]: change USB mouse to normal mouse

Your question #22887 on hal in ubuntu changed:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

    Status: Open => Answered

Bhavani Shankar proposed the following answer:
Ok..
Can you change the line in your xorg.conf from /dev/input/mice to
/dev/psaux and try i.e

sudo gedit /etc/X11/xorg.conf

In the Input device section it should look like this:
Section "InputDevice"
...
        Driver "mouse"
        Option "Device" "/dev/psaux"
...
EndSection

and keep us informed...

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887/+c
onfirm?answer_id=8

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

You received this question notification because you are a direct
subscriber of the question.

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.516 / Virus Database: 269.19.10/1240 - Release Date:
23/01/2008 17:47

Bhavani Shankar (bhavi) said : #12

To get back your xserver give the following command in recovery mode.. This happens due to incorrect editing of xorg.conf..

sudo dpkg-reconfigure xserver-xorg

As a last resort this article might interest you:

http://humanreadable.nfshost.com/sdeg/scroll-wheel-mouse.htm

Have a look.. If nothing works out.. then reinstall ubuntu...

Bhavani Shankar.

Michael Harrison (mh-aabac) said : #13

Hi Bhavani

I now have my xserver back by correctly editing the file through "remote
desk top" from my Windows box. I have read the article and applied the
suggestions but with no result.

As for re-installing 7.10, I started to do this but the screen just
displayed broad horizontal lines with some visible windows. I did not
have the confidence to continue and possibly ruin my system. I have
tried this on 3 computers and all with the same result. This "7.10" was
downloaded on 10th Jan.. The box I am currently running Ubuntu on first
had version 6 on it and has gradually been upgraded from the net so this
disk has never been used successfully.

I guess I will live with the RDT interface and forget the mouse problem.
I had a windows printer problem when I first moved to 7.10 which cured
itself with one of the upgrades. Hopefully this will do the same.

Thank you for all your efforts, it is appreciated.

Michael

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Bhavani Shankar
Sent: 24 January 2008 16:10
To: <email address hidden>
Subject: RE: [Question #22887]: change USB mouse to normal mouse

Your question #22887 on hal in ubuntu changed:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

    Status: Open => Answered

Bhavani Shankar proposed the following answer:
To get back your xserver give the following command in recovery mode..
This happens due to incorrect editing of xorg.conf..

sudo dpkg-reconfigure xserver-xorg

As a last resort this article might interest you:

http://humanreadable.nfshost.com/sdeg/scroll-wheel-mouse.htm

Have a look.. If nothing works out.. then reinstall ubuntu...

Bhavani Shankar.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887/+c
onfirm?answer_id=11

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

You received this question notification because you are a direct
subscriber of the question.

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.516 / Virus Database: 269.19.10/1240 - Release Date:
23/01/2008 17:47

Bhavani Shankar (bhavi) said : #14

hmm seems to be strange.. I am converting this question into a bug.. Please add comment about the diagnostics you did and please attach the files you edited as attachments..

Michael Harrison (mh-aabac) said : #15

Hi Bhavani

I have had a report of a similar bug:-

    Linked to bug: #108382
    https://bugs.edge.launchpad.net/bugs/108382
    "ps2 mouse does not work in Feisty FINAL VERSION"

But I can't believe that no one is using a PS/2 mouse!

Fyi the mother board is a VA-503+ from 1st Mainboard and has a VIA
Apollo MVP3 chipset. The manual is 1998. It is fitted with an AMD K6
processor.

My xorg.conf file reads:-

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/psaux"
 Option "Protocol" "IMPS/2"
 Option "ZAxisMapping "4 5"
 Option "Emulate3Buttons "true"
 Option "SendCoreEvents" "true" # added to force
multiple pointing devices to be recognised
EndSection

The "SendCoreEvents" (mentioned in the article you referred to) did not
help but I have left it in. There is no detrimental effect but I was
hoping that if the PS/2 mouse started working I would see it when both
"mice" are connected.

I do not know about software but I do know about hardware. It seems that
the driver "mouse" is picking up the wrong physical layer. Presumably
"Protocol" refers to the software protocol and not the physical layer.
If it was a real-time op. sys. I would expect to refer to a different
driver for a mouse connected to the USB bus (or lower level driver). If
the system was able to respond to either mouse, why are there not 2
entries under "InputDevice". One for each type of mouse. But perhaps
Linux works in a different way.

If you need me to try other things I will endeavour to find the time.

Thank you again

Michael

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Bhavani Shankar
Sent: 26 January 2008 05:52
To: <email address hidden>
Subject: RE: [Question #22887]: change USB mouse to normal mouse

Your question #22887 on hal in ubuntu changed:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

    Status: Open => Answered

Bhavani Shankar proposed the following answer:
hmm seems to be strange.. I am converting this question into a bug..
Please add comment about the diagnostics you did and please attach the
files you edited as attachments..

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887/+c
onfirm?answer_id=13

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.edge.launchpad.net/ubuntu/+source/hal/+question/22887

You received this question notification because you are a direct
subscriber of the question.

--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.516 / Virus Database: 269.19.13/1246 - Release Date:
27/01/2008 18:39

Bhavani Shankar (bhavi) said : #16

Yes... you are true...Strange behavior.. Please add a comment to that bug so it can be triaged..

Can you help with this problem?

Provide an answer of your own, or ask Michael Harrison for more information if necessary.

To post a message you must log in.