Problems connecting a usb-midi keyboard

Asked by GorArn on 2008-01-12

The CME M-KEY usb midi keyboard yields the following output using dmesg when connecting:

[29956.330913] usb 3-1: new low speed USB device using uhci_hcd and address 5
[29956.510041] usb 3-1: configuration #1 chosen from 1 choice
[29956.514002] unknown device speed 1
[29956.514013] snd-usb-audio: probe of 3-1:1.0 failed with error -5
[29956.514057] unknown device speed 1
[29956.514063] snd-usb-audio: probe of 3-1:1.1 failed with error -5

For some reason lsusb yields:

Bus 003 Device 005: ID 0471:0010 Philips

However, according to http://www.linux-usb.org/usb.ids there is no Philips device with device id 0010 but note that the CME entries in usb.ids are

7104 CME (Central Music Co.)
2202 UF5/UF6/UF7/UF8 MIDI Master Keyboard

so the Philips device ID is a permutation of the true ID for CME devices.

Then, the HAL Device Manager says that the device is CME M-Key and that it has two USB Audio interfaces and a USB raw device access but:

Device: unknown
Capabilities: unknown

Although the M-KEy device is not listed in usb.ids it is said to be "usb-midi class compliant". Can I "make it" into an ALSA mid device by simply editing some parameters somewhere?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
GorArn
Solved:
2008-01-14
Last query:
2008-01-14
Last reply:
GorArn (l-goran-arnoldsson) said : #1

Got the information from one of the experts on the field that the M-KEY device uses low-speed transfers which is not allowed for USB audio devices.
Future versions of kernel (2.6.23) and ALSA (1.0.15) will have a workaround. I'll simply wait until they arrive.

Marc Loid (b1308023) said : #2

The thread is old, but the problem seems to be ongoing.
I have the same keyboard and the output after connecting it is:

"new low-speed USB device number 3 using uhci_hcd"

I tried everything to get it work - withouth any success. Is it because USB audio devices aren't allowed on low-speed usb?