Logitech Express Camera and Ubuntu

Asked by Sweetness on 2007-11-28

Logitech Express Camera on a Hp Pavillon Computer which doesn't have windows at all just Linux Ubuntu.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2007-11-28
Last query:
2007-11-28
Last reply:
2007-11-28
Sweetness (cindym1997) said : #1

Ok I am using a Logitech Camera and it stays on all the time. I have to unplug it to stop working.
Or when my husband is using his it shuts my pick off but the camera is still on. Or When it working right, he can see me but I can't see him until I turn my camera off. I think there is a conflict somewhere causing my camera not to work right.
I have Linux Ubuntu 2008. I tried installing the thing from the site but I am confused with linux.. Is there a atomatic download and install for this Camera instead of me going in and typinga bunch of stuff..

Pedro Fragoso (ember) said : #2

Logitech Express Camera is supported with gspca.

Check https://help.ubuntu.com/community/Webcam

and install the package "gspca-source"

---- To install the webcam ( you must have an active internet connection ):
1) - We do all from terminal
2) - When the system ask you for password, give your user password, you don't see nothing when you type it, then press enter

Open a terminal from Applications->Accessories->Terminal and type:

sudo aptget update; sudo apt-get upgrade
sudo apt-get install camorama build-essential gspca-source linux-headers-$(uname -r)
cd /usr/src
sudo tar -xjvf gspca-source.tar.bz2
cd /usr/src/modules/gspca/
sudo make
sudo make install
modprobe gspca
camorama

If your cam color are no good open the: /etc/modprobe.d/options file

sudo gedit /etc/modprobe.d/options

and add this row at the end of file:
options gspca force_rgb=1

add the module gspca at the end of /etc/modules file, type:

sudo gedit /etc/modules

add a row at the end of file and type:
gspca

Save and exit and reboot your pc reopen Camorama from menu: Applications->Graphics->...

Give me some feedback
HTH

Sweetness (cindym1997) said : #4

Never got it to work right so I too the camera back and got a Phillips Web Camera and it seems to work. Took alot of tinkering to get it. Thanks for the help..

kat66 (kathrynivory) said : #5

followed instructions :) everything going great until asked for user password typed password in and it said "not found" now what do i do ?? ...help !

Maday (madayjd) said : #6

I have a Philips web cam and it used to work with Windows, but now I change to Ubuntu and It doesn't work... what can I do?