Need to disable onboard graphics

Asked by Larry on 2007-11-15

I have a nvidia geforce 8600 video card installed. When I got to change the setting in bios from agp to pci everything is fine. I can tell the graphics have changed while its booting up. When it gets too the point where it would load ubuntu it locks up. I assume its because my on board graphics card is conflicting with it. I already have the settings to auto in bio peripheral settings. In windows I could disable the onboard graphics from control panel. My windows came with the pc and is messed up so I can't use that to fix it. Have any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
Larry
Solved:
2007-11-20
Last query:
2007-11-20
Last reply:
2007-11-19
Peter Johnson (torfinn1000000) said : #1

Check and see if your bios has a setting that allows the operating system to make changes in the bios. If so then turn it off. Or if it is already turned off try turning it on, Also, if you had a non free driver installed for your previous video card you may need to go into your restricted driver settings and tell Ubuntu not to use it before switching to your new card. Change the restricted driver setting in Ubuntu first, then if that does not work try the bios configuration. I think that allowing the O/S to make changes in the bios is the correct setting to use though.

Hope that helps.

Larry (edickieson) said : #2

I appreciate the advice and still haven't gotten it to work and I tried a few different combos of things. The video card works, but when I get to the screen about boot local scripts it locks up. I'll figure it out sooner or later, but I keep having to reinstall ubuntu over and over so I can get it to work if I try something. I don't have any schooling in this stuff, but I've done my share of installing different cards and hard drives... simple stuff. With the Onboard graphics its a little more confusing. Before I just switched cards and was off lol. Thx though.

Torsten Spindler (tspindler) said : #3

Does booting the live CD work for you?

Larry (edickieson) said : #4

I have ubuntu installed ok and the live CD works as long as I dont have the driver for nvdia enabled. If I enable it, it locks up or I just see a fuzzy screen. Some of the files to do with installing restricted drivers are not working either so I may just reinstall the whole thing. I can always get the graphics card to work, just not with the ubuntu.