ISA Ethernet adapter not recognized

Asked by Blakeo_x on 2007-11-13

I recently popped a new Ethernet adapter into my computer's ISA bus and started the computer. Now Im trying to get Linux to recognize it so I can use it to connect to my network/the internet. The adapter is a 3Com EtherLink III (3C509TP). What do I do to get Linux to recognize the new hardware?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Last query:
2007-11-14
Last reply:
2007-11-14
Olivier (olivier-lacroix) said : #1

Hi !

add this line to the file /etc/modules

3c509

this will load the right module a boot as it seems that this card is not autodetected.

reboot.

Tell me if this helps !

Blakeo_x (blakeoxx) said : #2

It still isnt appearing in the network connection window. I tried adding 3c509, then 3c509tp. Neither worked.

Olivier (olivier-lacroix) said : #3

try adding

alias eth0 3c509

in the /etc/network/interfaces as suggested here http://ubuntuforums.org/showthread.php?t=363766

reboot

Olivier (olivier-lacroix) said : #4

oops not in /etc/network/interfaces but in /etc/modules

post here your /etc/network/interfaces

Blakeo_x (blakeoxx) said : #5

I added the lines to /etc/modules and the line to /etc/network/interfaces as the link said, then restarted. Still nothing.

My /etc/network/interfaces file contains these lines (minus the leading comments):

auto lo
iface lo inet loopback
iface eth0 inet dhcp

Blaxeo try to check if your 3c509 module is loaded open a terminal and type:

sudo lsmod | grep -i 3c509

if it is loaded the command will give back to you 1 row or more

if it isn't loaded try to load it manually, type:
modprobe 3c509 io=0x300 irq=0x10

Then redo the

sudo lsmod | grep -i 3c509

command

Please give us some feedback

HTH

Blakeo_x (blakeoxx) said : #7

After typing the first line you gave, I got 1 row of data back:

3c509 16084 0

Olivier (olivier-lacroix) said : #8

OK. that means the module is loaded. you should remove "iface eth0 inet dhcp" of the file /etc/network/interface as it may interfere with NetworkManager which handles now the connections in ubuntu.

then, enter in a console those commands :

sudo /etc/init.d/networking restart
sudo killall NetworkManager
sudo NetworkManager --no-daemon

and post the result here

Blakeo_x (blakeoxx) said : #9

The output I got from the last command is:

NetworkManager: <info> starting...
NetworkManager: <info> Updating allowed wireless network lists.
NetworkManager: <WARN> nm_dbus_get_networks_cb(); error received: org.freedesktop.NetworkManagerInfo.NoNetworks - There are no wireless networks stored...

Please give us the output of:

ifconfig -a

Thank you

Blakeo_x (blakeoxx) said : #11

lo Link encap:Local loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Olivier (olivier-lacroix) said : #12

It seems that isa cards are not that well supported, and that there is a bunch of thing to do

If you read french, have a look at http://doc.ubuntu-fr.org/materiel/isa

try to follow the steps there and give us feedback.

if you cannot understand anything, ask me

Blakeo_x (blakeoxx) said : #13

I dont speak French, but I used http://babelfish.altavista.com to translate the page.

It says I need ISAPNPTools, and gives a download link, but the link is broken. Where else can I get the program? Im running Ubuntu 7.10, in case you need to know.

Blakeo_x (blakeoxx) said : #15

Ok, I ran "sudo pnpdump > /etc/isapnp.conf" and got an output file. According to the page, Im supposed to replace some lines that "look correct". But, all the lines say "# Trying port address" along with an address, and the last line in the file says "# No boards found". The page doesnt say what to do if that happens.

Olivier (olivier-lacroix) said : #16

That's strange : linux does not detect at all your card...

Are you sure the hardware is functional ?

Olivier (olivier-lacroix) said : #17

post here the output of the following command

dmesg | grep isa

Blakeo_x (blakeoxx) said : #18

[ 0.000000] ACPI: Disabling ACPI support
[ 0.000000] Local APIC disabled by BIOS -- you can enable it with "lapic"
[ 21.406017] SELinux: Disabled at boot.
[ 23.202649] ACPI: Interpreter disabled.
[ 23.202773] pnp: PnP ACPI: disabled
[ 26.385132] audit: initializing netlink socket (disabled)
[ 26.409098] isapnp: Scanning for PnP cards...
[ 26.764510] isapnp: No Plug & Play device found
[ 27.202553] EISA: Probing bus 0 at eisa.0
[ 103.674011] lo: Disabled Privacy Extensions

Please be sure that your card has the default configuration irq=10 io=0x300

Check and reset your NIC values to default and DISABLE PNP on 3com NIC using the 3Com dos/windows software, see below:

Some here from 3com http://support.3com.com/infodeli/tools/nic/ethernet.htm
Related to your card: http://support.3com.com/infodeli/tools/nic/3c509.htm
-----------------------------------------------------------------------------------------------------------------------

Then try to load by command line the 3c509 kernel module with the appropriate parameter
modprobe 3c509 io=0x300 irq=0x10

Then add the module name put a new row at the end of the /etc/modules file, and type:
3c509

then edit the /etc/modprobe.d/options and add
options 3c509 io=0x300 irq=0x10

then reboot your pc.

Hope This Help

Can you help with this problem?

Provide an answer of your own, or ask Blakeo_x for more information if necessary.

To post a message you must log in.