Can't boot windows at all

Asked by ibstudent on 2007-10-11

This is my first experiment with linux at all, so sorry I don't even know the basics of the linux command line.

I installed Ubuntu 7.10 and I selected the option of creating a new partition just for ubuntu without erasing windows. Everything with Ubuntu seems to work fine, but when i turn on my computer it goes straight to Ubuntu without giving me an option to boot windows. I also can't figure out how to access my old windows files.

am i missing something simple?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
ex-xp64
Solved:
2007-10-14
Last query:
2007-10-14
Last reply:
2007-10-13
John Bruno (jbalaska) said : #1

Please post the output of;
sudo fdisk -l

And also post the contents of menu.lst;
sudo gedit /boot/grub/menu.lst

ibstudent (ibstudent) said : #2

none of this means much to me, but this is what it says. thanks so much for your help!

fdisk
--------------------------
Disk /dev/sda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc300c300

   Device Boot Start End Blocks Id System
/dev/sda1 1 4 32098+ de Dell Utility
/dev/sda2 5 3507 28137847+ 7 HPFS/NTFS
/dev/sda3 * 3508 7134 29133877+ 83 Linux
/dev/sda4 7135 7296 1301265 5 Extended
/dev/sda5 7135 7296 1301233+ 82 Linux swap / Solaris

menu.lst
---------------------
# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 3

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=0d88dac8-d4b8-4b3b-9ddd-2deaf9c03785 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,2)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Ubuntu 7.10, kernel 2.6.22-14-generic
root (hd0,2)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=0d88dac8-d4b8-4b3b-9ddd-2deaf9c03785 ro quiet splash
initrd /boot/initrd.img-2.6.22-14-generic
quiet

title Ubuntu 7.10, kernel 2.6.22-14-generic (recovery mode)
root (hd0,2)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=0d88dac8-d4b8-4b3b-9ddd-2deaf9c03785 ro single
initrd /boot/initrd.img-2.6.22-14-generic

title Ubuntu 7.10, kernel 2.6.22-12-generic
root (hd0,2)
kernel /boot/vmlinuz-2.6.22-12-generic root=UUID=0d88dac8-d4b8-4b3b-9ddd-2deaf9c03785 ro quiet splash
initrd /boot/initrd.img-2.6.22-12-generic
quiet

title Ubuntu 7.10, kernel 2.6.22-12-generic (recovery mode)
root (hd0,2)
kernel /boot/vmlinuz-2.6.22-12-generic root=UUID=0d88dac8-d4b8-4b3b-9ddd-2deaf9c03785 ro single
initrd /boot/initrd.img-2.6.22-12-generic

title Ubuntu 7.10, memtest86+
root (hd0,2)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

John Bruno (jbalaska) said : #3

In a terminal do ;
sudo gedit /boot/grub/menu.lst

Add the blocks of text below the ------, below this line: ### END DEBIAN AUTOMAGIC KERNELS LIST
Also you should change your default timeout section to 10
Example;

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 10

Save and exit, Then you should have a windows entry in your grub menu.
-------------------------------------------------------------------------------------Copy all below this line----

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Windows NT/2000/XP
root (hd0,0)
savedefault
makeactive
chainloader +1

ibstudent (ibstudent) said : #4

OK, we're getting closer. Now when it boots I can press ESC to reach the menu. I select the windows option and it flashes extremely quickly something about windows 95 (I'm running windows XP) and then it goes to some sort of test utility where you can select different diagnostics. Thats as far as it will go, if you close it, it just reboots. At least its recognizing something windows now. I think I should point out that when it starts to boot to windows I can see it loading all of these control files for the mouse and such.

Thanks again for the continuing and very quick help, i really appreciate it.

Best ex-xp64 (ex-xp64) said : #5

windows partition is sda2, so the menu.lst entry should read:

root (hd0,1)

If XP still doesn't boot, try making the partition active/boot (*):

sudo gparted

-->right-click on sda3/linux root>manage flags>uncheck 'boot'
-->right-click on sda2/windows>manage flags>check 'boot'

John Bruno (jbalaska) said : #6

Thanks ex-xp64, I totally missed that 0

ibstudent (ibstudent) said : #7

THANK YOU. you guys are my heroes. windows isn't nearly as good, but i didn't want to lose everything

thanks again

ibstudent (ibstudent) said : #8

Thanks ex-xp64, that solved my question.