Logitech Webcam Support Gutsy

Asked by Saitoh on 2007-09-30

I have a Dell XPS M1210 with a OEM Logitech webcam/microphone. The Device ID is 046d:08c6 making this fall under the UVC drivers. So I downloaded the UVC driver, edited the Makefile to "INSTALL_MOD_DIR := kernel/ubuntu/media/usbvideo" and attempted to make install. The webcam still doesn't work, nor has it for edgy or feisty. I am currently running gutsy and this issue was brought to my attention again because when I upgraded to gutsy it erased my previous configuration which after weeks of messing around I was able to get Ubuntu to stop sending massive amounts of power to the camera which makes it really hot and kills my battery life.

Anyways my fstab looks like so:

proc /proc proc defaults 0 0
# Entry for /dev/sda4 :
UUID=0d2e4fa4-551b-4d4c-aecc-cd75f8e0580c / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/sda1 :
UUID=07D7-0406 /media/sda1 vfat defaults,utf8,umask=007,gid=46 0 1
# Entry for /dev/sda2 :
UUID=D62CB0C32CB0A043 /media/sda2 ntfs-3g defaults,locale=en_US.UTF-8 0 1
# Entry for /dev/sda3 :
UUID=3f78cd3b-0692-4094-aeb7-e4653bc3f807 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0

it has all of my hard drive partitions mounted, but I don't see my camera anywhere. Any help would be really appreciated.

update:
If i run "modprobe uvcvideo" I get nothing

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
Saitoh
Solved:
2007-09-30
Last query:
2007-09-30
Last reply:
2007-09-30
Nicolas DERIVE (kalon33) said : #1

Hello,

your camera shouldn't appear in the fstab, but eventually with "lsusb" or "lspci" commands.

I saw in UVC web site (http://linux-uvc.berlios.de/) : "Starting at version 2.6.22, the Linux kernel includes a USB audio bug fix which triggers a (possibly identical to the above) bug in first and second generation Logitech webcams. See the Linux UVC wiki for a workaround." : Did you try this workaround ?

After a "sudo modprobe uvcvideo" : Try this (after installing mplayer) : mplayer tv:// -tv driver=v4l:width=640:height=480:device=/dev/video0

                                                         Or install "cheese" and try to launch it.

Do you have any picture ?

Hope that it helps.

--kalon33

Saitoh (awbailey001) said : #2

I was able to install the WebCam by doing the following:

1. To get the UVC driver type "svn checkout svn://svn.berlios.de/linux-uvc/linux-uvc/trunk"
2. Now go the folder trunk by opening a terminal and typing"cd trunk"
3. You need to change the install path in the Makefile so type
     "sudo vi Makefile" and change
     INSTALL_MOD_DIR := usb/media
     to
     INSTALL_MOD_DIR := kernel/ubuntu/media/usbvideo
4. Then you need to compile it so type "sudo make install". Your webcam driver is now installed, but you still need a program to use it and most
    are not compatible with the UVC drivers (easycam will not work 99% of the time).
5. So go here http://mxhaard.free.fr/spca50x/Investigation/uvc/ and get the latest luvcview.tar.gz file.
6. You now need to extract the files so go to where you downloaded them to usually the desktop ("cd ~/Desktop/") and type "tar -xzf luvcview(here you
    need to put the rest of the file name which changes depending on what version you are using.)".
7.You now need to install some lib files so open synaptic package manager and search for "SDL", you need to install a lib file named "libsdl1.2-dev" there
   are several similar named libs that are installed in Ubuntu by default so make sure you click that one.
8. Now you need to go back to your terminal go do the folder that was created by step 6 and type "sudo make install" .
9. Your all done just type luvcview and a window will pop up with the video from your webcam.

I tried to make this as newb proof as possible I got all my information from:
http://linux-uvc.berlios.de/
and UVC's wiki:
http://openfacts.berlios.de/index-en.phtml?title=Linux+UVC

So if you have problems these places will give you answers.

Can someone newb it down more? I've only been working with Linux for about a week.

Saitoh (awbailey001) said : #4

what specifically do you need help with?

After step 2 it don't want to work right for me. LOL

Let me rephrase that. On step 3 I can't get Terminal to do anything. It just freezes when it displays the "makefile" structure.

Ok guys I got around my hang up and followed the steps (I think. Half asleep here) and I get this error message at the end of it.

luvcview version 0.2.1
Video driver: x11
A window manager is available
video /dev/video0
Error opening device /dev/video0: unable to query device.
 Init v4L2 failed !! exit fatal

Saitoh (awbailey001) said : #8

First off make sure you installed the right libs. Next, you get the error when you type
the luvcview or at some other step?

Saitoh (awbailey001) said : #9

*luvcview command

Saitoh (awbailey001) said : #10

also paste the output of the "lsusb" command.

Saitoh (awbailey001) said : #11

also make sure you have the following library's installed:
libc6
libsdl1.2debian

Bus 002 Device 007: ID 062a:0000 Creative Labs Optical Mouse
Bus 002 Device 008: ID 05dc:a720 Lexar Media, Inc.
Bus 002 Device 003: ID 0bc2:0503 Seagate RSS LLC
Bus 002 Device 004: ID 0409:005a NEC Corp.
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 0f30:0107 Jess Technology Co., Ltd
Bus 001 Device 003: ID 058f:9254 Alcor Micro Corp. Hub
Bus 001 Device 002: ID 046d:0a03 Logitech, Inc.
Bus 001 Device 001: ID 0000:0000

The error message was after I entered the luvcview command.

Oh, And I already had those library files installed.

Saitoh (awbailey001) said : #15

Ok, I solved your problem. First the driver that I use in this example doesn't support your web cam.
However, the following drivers supposedly do:

http://blognux.free.fr/sources/debian-cam/usr/share/

If your running Ubuntu this is probably already in the universe repos(named easycam).
I would try to install it from there, if it doesn't work then try the newer version at the
above web address.

Saitoh (awbailey001) said : #17

Unfortunately that is for the web cam with the ID 046d:08c6 which is the standard for the Dell M1210.
Emerald_knight has a web cam with the id 058f:9254 and a separate microphone with id 046d:0a03.