Compiz Fusion on Nvidia HP Laptop won't shut down

Asked by warh34d on 2007-09-09

Hi all... I'm kind of noob in ubuntu... I need some help with compiz-fusion... I installed it the other day but since then I just can't shut it down... If I try to log out or shut down or restart the computer, the system hard crashes and needs hard reset... The only thing still operational is the mouse... Other than that, it works perfectly... Any ideas?

Question information

English Edit question
Ubuntu hal Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
François Tissandier (baloo) said : #1

If you deactivate Compiz, can you shut down?

warh34d (emc2-man) said : #2

nop... that's exactly my point... I CAN'T deactivate it! the system stalls and needs hard reset

François Tissandier (baloo) said : #3

Ok, could we have some more info plz?
-distro version? edgy? feisty? Gutsy?
-how did you install compiz?
-graphic card? Nvidia? ATI? Intel?
-which driver for the graphic card are u using?


warh34d (emc2-man) said : #4

ok... I installed it using a guide ubuntu ultimate feisty on HP Laptop Pavilion DV9393... Nvidia Geforce Go 7600 512 MB... 2GB Ram... Intel Core 2 DUO 2GHz... i have the standard updated drivers... not the "new" ones...

François Tissandier (baloo) said : #5

Ok. My opinion on this problem: as Compiz is quite "cutting edge"
technology, and you are running an almost "old" version of Ubuntu,
personnally I would just live without Compiz Fusion for some more weeks
(and maybe use the included version of Compiz, even if it's less
advancedd), wait for Gutsy to be released, and upgrade. That would
probably save you some work.

Please remember that by installing softwares like this, it may lead to
this kind of instability. To work with the official repo is always
better in terms of stability. Of course it's nice to try new softwares,
but you may meet this kind of problem.

But if you still want to use Compiz Fusion, we can investigate a bit
more what's wrong.

warh34d (emc2-man) said : #6

Thnx a lot for the help... I really appreciate it... But I'm kind of a maniac with desktop effects... And I really believe I can solve this... Another Forum told me it has to be something with indirect rendering... Any ideas in that field? (I don't really know what it does...:P)

François Tissandier (baloo) said : #7

ok, let's find a solution then.

How do you try to shut Compiz down?

Did you try a simple 'metacity --replace' ?

warh34d (emc2-man) said : #8

Yes... that's the exact command i used..

François Tissandier (baloo) said : #9

Ok... and if you try
'killall compiz"
or "killall compiz.real" ?

warh34d (emc2-man) said : #10

Ok I got it... The tip was indirect rendering...Once i disabled it everything works just fine... Thanks a lot for the help

François Tissandier (baloo) said : #11

Great, enjoy your system then :)