Trouble on IBM lenovo T60 with ati graphics card

Asked by likeathiefinthenight on 2007-09-02

I just got a brand new IBM lenovo T60 but I can't run unbunu 7.04. The install goes fine but when I restart without the boot disk it gives me errors with the x-server. Any ideas? I tried updating the packages (sudo apt-get install xorg-driver-fglrx fglrx-control) etc., etc.

Is it possible to actually get ubuntu running properly on this laptop?

Any help appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Last query:
2007-09-03
Last reply:
2007-09-04

No, not really. I tried this before. my graphics card is a ATI mobility Radeon X1400.
I'll try it again because this looks like it should solve my problem. I'll write back with my results in the morning.

No this didn't solve my problem. I still attempt to start up ubuntu and get an x-server error and it says "no screens found".
I went through all the steps while booted up on the Live CD. Is this correct? It's the only way I could get into ubuntu. I got all the way down the steps until it says to check fglrx info and it still gave me the mesa info. I continued the steps but they didn't seem to make a difference.

No you need to the steps in your Ubuntu install on your hard drive and for the step where it says to use gedit or kate use vim or nano instead. When it says x-server not found it should drop down into a command-line interface. If it doesn't, boot into recovery mode and follow the directions that way. If you still are having problems let me know.

Can you help with this problem?

Provide an answer of your own, or ask likeathiefinthenight for more information if necessary.

To post a message you must log in.