can´t boot into ubuntu

Asked by gakna on 2007-08-30

Hi everybody! sorry if am too explicative but i am new to ubuntu. After a lot of problems i managed to reconfigure my ATI Radeon 9250 and have 3D acceleration. Then i installed compiz fusion and worked fine. Then i installed the unofficial plugins: "compiz-fusion-plugins-unofficial" in order to see the 3D effects buy they didn´t work so i disabled them in the Compiz Manager. Then i installed some desktop themes (T-ish for Clearlooks and OSX iconset, and a bacground for the desktop and downloaded an icon theme: Innex which i didn´t install), and tried to connect and do a hotsync with my PDA sony clie but Ubuntu didn´t recognize it so i tried to configure the PDA program that comes with Ubuntu and didn´t know how so i left it (i might have change some settings in that program but don´t remember which). Ubuntu was working fin other than that. Next day when i tried to boot into ubuntu i saw the Ubuntu bar and then...black, nothing...couldn´t get into the X. I got into recovery mode and put: "sudo /etc/init.d/gdm restart" and could enter!!!. When it opened showed me an error: "Failed to initialize HAL", but other than that everything worked, even compiz fusion. I restarted and could enter again but as i shut down same black screen again. I tried the command "sudo /etc/init.d/gdm restart" in recovery mode again but this time didn´t work, neither to reconfigure the xorg.org, nor nothing, i can´t get into the X. Yesterday i tried: "sudo dpkg-reconfigure gdm" and then "startx" and worked, i restarted and worked again with the same error. But again, as i shut down couldn´t get in again and the command didn´t work anymore. Strange...and more for a newbie...Any ideas??? believe me i searched and tried everywhere...Thanks in advance to everybody...:)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Last query:
2007-09-01
Last reply:
2007-09-01

try running
 sudo dpkg-reconfigure xserver-xorg

gakna (gakna) said : #2

Hi, i did what you suggested, reconfigured everything (just choosed ATI and put the model, and the rest i selected the options that were given) and then i put "startx" and it worked. I entered the desktop but it was plain, without the changes that i had made. Then i restarted and MY desktop opened, with all my changes and compiz fusion working. Then i shut it down, and when i tried to boot there was the black screen again. It`s strange that when i tried to reconfigure something i could get in and if i restart i can get in too BUT if then i shut the computer down it doesn´t let me in anymore. no idea what that means...
Ah, this time there wasn´t any "Failed to initialize HAL" error.

I'm interested in your question....
Can you, tell us what version of Ubuntu you are using...?
Form a terminal do a cat /etc/issue to see it
Thank you.

gakna (gakna) said : #4

Hi, thanks for helping me :)
I did what you asked and it is: Ubuntu 7.04 \n \l

gakna (gakna) said : #5

Any ideas?? or should i reinstall everything maybe...

I' m confused, if you use some different than ATI your computer works fine...?
can you try this:
at boot don't make login
press ctrl+alt+F2
ad login with your user and password
after that type:
sudo dpkg-reconfigure -phigh xserver-xorg
choose vesa as graphic card, and test if your graphic environment works.
When it works, go to a terminal and make a backup copy of your xorg.conf working file to do this open a terminal and type:
cd /etc/X11
sudo cp xorg.conf xorg.conf.sic
If all works then try to reconfigure your xorg.conf
If something go wrong then restore your xorg.conf.sic

Here something solved ATI 9250 related
https://answers.launchpad.net/ubuntu/+question/5281
http://ubuntuforums.org/showthread.php?t=415323&highlight=fglrx+9250

HTH

Can you help with this problem?

Provide an answer of your own, or ask gakna for more information if necessary.

To post a message you must log in.