about gvfs-bin 1.46-1 is needed by some software

Asked by Asbjørn on 2020-10-23

i've been using gitkraken and other software. until ubuntu 20.04 no problem at all, because gvfs-bin was included. i searched and the version 1.46 of this package exists, at least on debian. are you going to port this for ubuntu 20.10? or i should report a bug to gitkraken to change the dependencies of this package?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gvfs Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :
#1

The package description tells
gvfs-bin: userspace virtual filesystem - deprecated command-line tools

And the Change log tells:
* Revert adding back the gvfs-bin package, it's not needed in Ubuntu

Apparently the removal of gvfs-bin from Ubuntu 20.10 was on purpose.

I see the following options:
* Stay on Ubuntu 20.04
* Ask gitkraken to provide a version that does not depend on gvfs-bin
* Build your own version of gitkraken that does not depend on gvfs-bin
* (Eventually: Manually install the version for Ubuntu 20.04 on 20.10, if that is possible at all)

Revision history for this message
Asbjørn (eldarberserker) said :
#2

Thanks Manfred Hampl, that solved my question.

Revision history for this message
Asbjørn (eldarberserker) said :
#3

i just managed to install gvfs 1.44 from ubuntu 20.04 to get this package, and I submitted a report to gitkraken to update their dependencies on their software.

Revision history for this message
Bernard Stafford (bernard010) said :
#4

This was a proposal that was being discussed at GitHub:
From the GitHub: [For gitkraken] to replace gvfs-bin by libglib2.0-bin (for gio open to replace gvfs-open)
Package: libglib2.0-bin (2.66.1-2)
https://packages.ubuntu.com/groovy/libglib2.0-bin