/usr/share/gvfs/mounts/network.mount gone missing

Asked by Peter on 2012-09-12

In xubuntu 12.04 I used to have a file /usr/share/gvfs/mounts/network.mount but it has vanished.

I want to set AutoMount to false

What is normally in that file or where has it been moved to ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gvfs Edit question
Assignee:
No assignee Edit question
Solved by:
Peter
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

andy@fileserver:~$ cat /usr/share/gvfs/mounts/network.mount
[Mount]
Type=network
Exec=/usr/lib/gvfs/gvfsd-network
AutoMount=true

andy@fileserver:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

You can now remake the file. This is from a clean install

Revision history for this message
Peter (nitep) said :
#2

Thanks for that. I have restored that file and rebooted the system but it still wastes time mounting partitions I dont always use even though I set AutoMount=false so something else has changed in the system.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

Are the partitions on internal drives?

Revision history for this message
Peter (nitep) said :
#4

Yes

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5

If you add them in /etc/fstab and add the option 'noboot' and it will not be mounted atboot

Revision history for this message
Peter (nitep) said :
#6

Thunar used to be extemely slow on startup.
On googling this I found a reference to setting AutoMount=false in /usr/share/gvfs/mounts/network.mount
This made thunar extremely fast to start and I mounted whatever I needed with the Disk Utility app
The USB and extra partitions did not show in thunar's side pane until mounted.
With recent system updates thunar starts slowly and USB devices are auto mounted and extra partitions show as mounted with and eject symbol beside them but when I click on the extra partitions it is reported that they need to be mounted.
As I said earlier AutoMount=false in /usr/share/gvfs/mounts/network.mount is now ignored for USB devices as well.

My system was ugraded a while ago to Unity which I did not like and then had Xubuntu desktop installed on top of it followed by 2 xubuntu upgrades so I will do a fresh install of xubuntu 12.10 when it is out.
Hopefully by then it will be sorted. It was nice having a very fast system for a while.