Archive mounter mounts in read-only

Asked by myky on 2011-12-21

I have installed fuse-zip Archive Mounter for Nautilus and my problem is that it mounts the archive in read-only mode for the default user, however I do it manually through the terminal commnad line using fuse-zip. I can than only mount using a root account.

So there is a problem in Nautilus to copy any files, since the volume indicated to be read-only one.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gvfs Edit question
Assignee:
No assignee Edit question
Solved by:
myky
Solved:
Last query:
Last reply:
Revision history for this message
myky (zemnon) said :
#1

Ubuntu version is 10.10

Revision history for this message
delance (olivier-delance) said :
#2

Did you succeedded top mount in write mode for root ?

Revision history for this message
myky (zemnon) said :
#3

yes, but from the command line, since the Archive Mounter option is not available in the nautilus ran under root. Even if I choose run as -> archive mounter, it does not work even for root.

However from the command line with fuse-zip I've managed as root to mount the archive in read-write mode, however for the normal user it is read-only.

I would appreciate much any suggestion

Revision history for this message
myky (zemnon) said :
#4

Hi guys,

do you have any suggestions?

Thank you in advance.

Revision history for this message
Launchpad Janitor (janitor) said :
#5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
myky (zemnon) said :
#6

I still have not managed to mount the archive in read-write mode under a normal user in nautilus.

Revision history for this message
Sam_ (and-sam) said :
#7

Websearch finds lots of archiv mounter 'user inability to write to archives'.
For example .iso images aren't 'user writeable'.
http://ubuntuforums.org/archive/index.php/t-1134056.html

Revision history for this message
myky (zemnon) said :
#8

Hi Sam,

Thanks for the update. The archive I was trying to mount is a created zip with a single file, which I have created a minute ahead before mounting. So I assume it should not be read only, but please advise if you know more.

Do you know in which file are situated the settings for the fuse command of nautilus?

Thank you.

Revision history for this message
Sam_ (and-sam) said :
#9

Not sure if user writeable is intended, when opened with file-roller files can be added and removed.
Maybe consider to report a bug that gvfs-mount should mount archive rw.

Revision history for this message
myky (zemnon) said :
#10

thanks for the idea, will report a bug. Thanks for help.