Window updates much slower under 12.04 than 10.10

Asked by Ron Johnson


I just upgraded from GNOME 2.32 on a PPA-loaded Maverick 10.10 to 12.04 using GNOME Classic No Effects.

Window updates are noticeably slower in apps like gnome term, pysolfc and nethack-x11, while some gtkperf tests are significantly slower on my machine than on my wife's slower machine.

I ran it under all of the Unity and GNOME variants and the times weren't significantly different.

This is a list of the significantly slower gtk operations (along with a couple of faster operations):

We both have the nvidia 295.40 driver installed.
She still runs a PPA-loaded Maverick system.

My system has an Athlon II X4 640 CPU with GeForce 210 GPU while she has a Phenom II X2 555 with 8400GS GPU. Does screen size matter?

Is this a known upstream regression? What package should I file a bug under?


Question information

English Edit question
Ubuntu gtk+3.0 Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Can you please give the output of:

sudo lshw -C display; lsb_release -a: uname -a; dpkg -l | grep nvidia

Thanks, also did you upgrade witha clean install or did you upgrade to every release between Maverick and Precise?

Revision history for this message
Ron Johnson (ron-l-johnson) said :

Clean install from the 64 bit Live DVD. (Since /home is on it's own partition, I'm able to upgrade w/o much worry.)

# lshw -C display
       description: VGA compatible controller
       product: GT218 [GeForce 210]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:18 memory:fb000000-fbffffff memory:b0000000-bfffffff memory:ce000000-cfffffff ioport:ef00(size=128) memory:c0000000-c007ffff

# lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:cxx-4.0-amd64:cxx-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

# uname -a
Linux haggis 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
# dpkg -l | grep nvidia
ii nvidia-common 1:0.2.44 Find obsolete NVIDIA drivers
ii nvidia-current 295.40-0ubuntu1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver

Revision history for this message
actionparsnip (andrew-woodhead666) said :

If you copy and pasted the command I gave, it would not only be easier for you but would also remove any user error. In future, please run commands as given.

If you run:

sudo nvidia-xconfig

Then reboot, it may help

Revision history for this message
Ron Johnson (ron-l-johnson) said :

What user error????

Revision history for this message
Ron Johnson (ron-l-johnson) said :

"sudo nvidia-xconfig" + reboot had no effect on gtkperf.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Your monitor may not be reporting its ability and so loading the video driver with different options, the xorg.conf file made tells the driver to load with different options

Revision history for this message
Ron Johnson (ron-l-johnson) said :

The monitor, video card and binary driver are the same today as they were 48 hours ago (when I upgraded).

What's changed since Sunday afternoon are new versions of:
  Linux kernel (3.0.6 -> 3.2.0)
  X Windows (7.5 -> 7.6)
  Gtk (2.22 -> 3.4.1)
  GNOME(2.32 -> 3.4.1)
  Window Manager (metacity -> mutter)

So, since the hardware and binary driver haven't changed, what do I file the regression bug against?

Revision history for this message
Sam_ (and-sam) said :
Revision history for this message
Ron Johnson (ron-l-johnson) said :

The desktops (since I tried gtkperf on Unity, Unity2D, Gnome3, Gnome Classic and Gnome Classic No Effects) are definitely *usable*, just noticeably slow to update windows.

This ( comment refers to only getting 5fps in glxgears while I get 3400fps and Tux Racer is definitely playable.

Thus, OpenGL apps perform *well* for me.

So it's definitely a 2D issue.

Revision history for this message
Ron Johnson (ron-l-johnson) said :

Since (a) I haven't used the deprecated nv driver in way more than 5 years, and (b) xserver-xorg-video-nv does not exist in Precise, I'm confused as to why this question wuld be reassigned to that package.

Revision history for this message
Sam_ (and-sam) said :

No idea who assigned to nv, I've changed it to gtk-3.0 according to bug report.
On top of this page right hand corner is a entry 'edit question'.

Can you help with this problem?

Provide an answer of your own, or ask Ron Johnson for more information if necessary.

To post a message you must log in.