libgtk2.0-dev won't install on gutsy

Asked by Kristopher Ives on 2007-11-06

Hi, I'm attempting to get some of the gtk development libraries to install using the offical repos. I'm a fan of using Synaptic instead of apt-get or aptitude directly (since it seems to keep me better informed), but attempting to install libgtk2.0-dev yeilds:

libgtk2.0-dev:
 Depends: libpango1.0-dev but it is not going to be installed

I checked libpango1.0-dev and it won't install because:

libpango1.0-dev:
  Depends: libpango1.0-0 (=1.18.2-0ubuntu1) but 1.18.3-0ubuntu1 is to be installed

I looked at my available versions of libpango1.0-0 and it has:
1.18.2-0ubuntu1
1.18.3-0ubuntu1

Is it safe to force version to 1.18.2-0ubuntu1 ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gtk+2.0 Edit question
Assignee:
No assignee Edit question
Solved by:
Cesare Tirabassi
Solved:
2007-11-06
Last query:
2007-11-06
Last reply:
2007-11-06
Best Cesare Tirabassi (norsetto) said : #1

Most probably you have the gutsy-proposed repository enabled in sources.list.

libgtk2.0-dev | 2.12.0-1ubuntu3 | gutsy
libpango1.0-dev | 1.18.2-0ubuntu1 | gutsy
libpango1.0-dev | 1.18.3-0ubuntu1 | gutsy-proposed
libpango1.0-0 | 1.18.2-0ubuntu1 | gutsy
libpango1.0-0 | 1.18.3-0ubuntu1 | gutsy-proposed

Kristopher Ives (nullmind) said : #2

Thanks, I removed the extra repos (it was either a security update or recommended update), but the libpango version is still the newer version, and any attempt to screw with it says it will be removing my entire package library!

Is there a way to forcefully install this library down to another version?

Cesare Tirabassi (norsetto) said : #3

You can downgrade libpango by simply installing the older version. You can do this by opening a terminal and giving this command:

sudo apt-get install libpango1.0-0=1.18.2-0ubuntu1

Kristopher Ives (nullmind) said : #4

If I attempt to do that I get:

The following packages will be REMOVED:
  alacarte compiz compiz-gnome evolution evolution-exchange evolution-plugins
  fast-user-switch-applet gdm gnome-applets gnome-control-center gnome-panel
  gnome-session gnome-terminal libedataserverui1.2-8 libexchange-storage1.2-3
  libgnome-window-settings1 nautilus nautilus-cd-burner sound-juicer
  ubuntu-desktop
The following packages will be DOWNGRADED:
  libpango1.0-0
0 upgraded, 0 newly installed, 1 downgraded, 20 to remove and 0 not upgraded.
Need to get 293kB of archives.
After unpacking 49.4MB disk space will be freed.
Do you want to continue [Y/n]?

And I do need those packages!

Thanks for the help so far,
Cheers,
Kristopher Ives

Cesare Tirabassi (norsetto) said : #5

I can only see three possible ways to solve this:

1) Proceed with the removal of the newer pango and manually reinstall all the removed packages. Most probably re-installing just ubuntu-desktop would do, otherwise it must be done manually

2) Install the newer libpango-dev library. Since it is versioned as a dep of libgtk2.0-dev only as >= 1.10.0-2 you should be able to install libgtk without problems.

3) Use dpkg to downgrade (for instance with --force-downgrade).

Of the 3 the most appropriate for you I think is 2, it requires you to re-enable the gutsy-proposed repository, and install it with "sudo apt-get install libpango1.0-dev", after which you should be able to install libgtk2.0-dev.