flacparse: early EOS (bugzilla bug #682959) seems not fixed in Ubuntu 12.04

Asked by g.ptic on 2014-02-21

Hello!

I just reported a bug in SoundConverter about converting FLAC files produced truncated output files:
https://bugs.launchpad.net/soundconverter/+bug/1282979

It turned out that this was a known problem, which apparently was fixed in gstreamer back in 2012:
https://bugs.launchpad.net/soundconverter/+bug/1041842
https://bugzilla.gnome.org/show_bug.cgi?id=682959

Will this fix be applied to the Ubuntu Precise package as well at some point?

Thank you!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gst-plugins-good0.10 Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel Letzeisen
Solved:
2014-02-22
Last query:
2014-02-22
Last reply:
2014-02-22

Probably not. Unless Soundconverter destroys the original FLAC, the issue is not severe enough to warrant an SRU: https://wiki.ubuntu.com/StableReleaseUpdates

If you can point me to the git commit (in the gstreamer 0.10 git) that fixes the issue, I can try to make a patched version in my PPA. Unfortunately, in the bugzilla, the dev just said it was fixed a while ago but did not give the commit link.

g.ptic (g.ptic) said : #3

Thanks for your reply, I understand.

In the meantime, if you know of a simple workaround in Ubuntu LTS 12.04 (with your PPA maybe?), I would be grateful for any hint.

g.ptic (g.ptic) said : #4

Thanks Daniel Letzeisen, that solved my question.

It's going to take a bit of time to push the packages to my PPA. I will let you know if I succeed and when it's ready for testing.
https://launchpad.net/~dtl131/+archive/ppa?field.series_filter=precise

For some reason, the build keeps hanging on Ubuntu's build server, even though it works fine in my Precise VM :\

If you're really interested, let me know and I'll give you instruction on how to build a patched package. Otherwise, I would just suggest not using Soundconverter and seeing if you can do the job with command-line tools/scripts instead.

g.ptic (g.ptic) said : #7

Hi Daniel, thank you very much for your efforts to fix this.

Since building packages is a bit beyond my skills, I think that I will just wait for the next LTS, where the problem will hopefully be fixed. In the meantime I can use other applications (like XFCA) that are not affected by this problem.

Again, thanks!