Ubuntu

Grub error 17

Asked by Matthew M on 2010-01-25

I had been running only Ubuntu on my HP Pavilion notebook, and then on a whim the other day installed Crunchbang Linux on a 3 GB partition. I did something silly just now and deleted my Crunchbang partition manually using the Ubuntu disk editor. Now when I boot up I get a grub error 17 message. I'm not certain what exactly that means-- unable to mount selected partition, I think? Attempts to run the Ubuntu live disk in the CD tray also produced an error 17 message.
I'm now using my Crunchbang live USB key.

results of $ sudo fdisk -l :

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x302bd63d

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 29041 233271801 83 Linux
/dev/sda2 29042 30401 10924200 5 Extended
/dev/sda5 29346 29367 176683+ 82 Linux swap / Solaris
/dev/sda6 29368 30401 8305573+ 82 Linux swap / Solaris

Disk /dev/sdb: 4005 MB, 4005527552 bytes
124 heads, 62 sectors/track, 1017 cylinders
Units = cylinders of 7688 * 512 = 3936256 bytes
Disk identifier: 0x00065765

   Device Boot Start End Blocks Id System
/dev/sdb1 * 1 1017 3909317 b W95 FAT32

I tried to follow a tutorial online for the error which seemed like it might help: http://stringofthoughts.wordpress.com/2009/05/24/grub-error-17-debianubuntu/

and got as far as the grub > root stage before the suggested steps stopped working and I decided I really didn't have any idea what I was even doing... which led me here!

If you need any more information just let me know; a fast fix would be wonderful as I am a university student and access to my computer is pretty crucial! Thanks for any help you can offer.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
Matthew M
Solved:
2010-01-25
Last query:
2010-01-25
Last reply:
2010-01-25
Vitaliy Kulikov (slonua) said : #1

So, U can look on this http://grub.enbug.org/Manual#GrubShell

Also, u can try start with following:

$ linux /vmlinuz ro
$ initrd /initrd.img
$ boot

If this boots open a terminal:

$ sudo update-grub

BTW, Could U provide output:

$ uname -a

What version of Grub do U have installed ?

Matthew M (mmanassis) said : #2

I don't really know what to make of the Grub manual, sorry.

Output from those first three commands you gave me:

crunchbang@crunchbang:~$ linux /vmlinuz ro
The program 'linux' is currently not installed. You can install it by typing:
sudo apt-get install user-mode-linux
bash: linux: command not found
crunchbang@crunchbang:~$ initrd /initrd.img
bash: initrd: command not found
crunchbang@crunchbang:~$ boot
bash: boot: command not found
crunchbang@crunchbang:~$

Output from uname -a:

crunchbang@crunchbang:~$ uname -a
Linux crunchbang 2.6.28-13-generic #45-Ubuntu SMP Tue Jun 30 19:49:51 UTC 2009 i686 GNU/Linux

I don't remember what version of Grub I have installed. In the "boot" folder in my now-unreachable filesystem, it seems to just be labelled "grub," if that's of any use to you. I was running Ubuntu 9.10, and then Crunchbang 9.04, which is based on Ubuntu 9.04. I'd imagine that whatever version of Grub was released with either of those would be the version I have, but I really don't know which version that would be.

Matthew M (mmanassis) said : #4

Thanks for the help everyone, I ended up just taking the easy way out and reinstalling Ubuntu entirely.

Iqbal (naqvi-iqbal2001) said : #5

Hi,
I also got almost same problem. As you told u have removed Crunchbang Linux. The MBR (Master Boot Record) has entries for both the OS. Now u have deleted one. So MBR is searching the Crunchbang Linux but it is not finding it. So it is giving error.
After deleting the Crunchbang linux, u should have fixed MBR at that time only.

Now u either fix the MBR or install Ubuntu afresh, as I did and got through.