Grub2 reports "error:the initrd is too big"

Asked by Minakov Arthur on 2009-11-15

PC: Duron 600MHZ; 256MB RAM; RivaTNT 32MB; 2GB HDD ((hda)/,SWAP:512MB) + 20GB ((hdb)/usr,/home) -ext3 fs
MBR is on hda, disk formatted normally, system installed without any errors, but after GRUB menu there is "error:the initrd is too big"
LiveCD boot normally.
How can I fix this error?

Question information

English Edit question
Ubuntu grub2 Edit question
No assignee Edit question
Solved by:
Colin Ian King
Last query:
Last reply:
Minakov Arthur (spydefender) said : #2

Award BIOS.. I didn't find anything like "memory hole", sorry

You could boot to recovery root console and reinstall the kernel on the CD.

Minakov Arthur (spydefender) said : #4

I try to reinstall Karmic, but this message shown again. Can you print step-by-step kernel re-installation, or list of commands for it? man pages - teacher for mind.

Minakov Arthur (spydefender) said : #5

mkinitrd didn't change anything. Simple copying Debian worked initrd and renaming it also unuseful...
Memory test show me some I/O errors, but Debian, puppyrus, WindowsXP works fine. Question still opened

Best Colin Ian King (colin-king) said : #6

This bug is reported in LaunchPad here:

Minakov Arthur (spydefender) said : #7

Thanks Colin King, that solved my question.