cannot find operating system

Asked by Richard A sweeny on 2019-04-04

I am running Windows 10 and Ubuntu 18 on separate partitions on a Dell Inspiron 3000 laptop. When I start the computer I get a screen stating "No operating system found' with a button to shut down. I restart the computer holding the f12 key to choose my boot disk. I select the internal hard drive and I get the Grub boot loader. I can choose Windows or Ubuntu and boot into either one normally. Why can it not see the operating system on the initial boot?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
Richard A sweeny
Solved:
2019-04-04
Last query:
2019-04-04
Last reply:
2019-04-04
Manfred Hampl (m-hampl) said : #1

My suspicion is that the "bootable" flag is missing on the hard disk with grub.

I suggest that you run boot-info, and check the information at the end of the report.
https://help.ubuntu.com/community/Boot-Info

If my assumption is correct, then running boot-repair would probably set that flag.
https://help.ubuntu.com/community/Boot-Repair

Richard A sweeny (rasweeny) said : #2

I ran Boot-info and generated this report: http://paste.ubuntu.com/p/z6WZJ3Q3tX/

I also ran Boot-repair and generated this report: http://paste.ubuntu.com/p/Rs4CjP5N9M/

After running Boot-repair it still does not see the operating system. Could this be a Windows problem?

Manfred Hampl (m-hampl) said : #3

ok, next idea:
What does the BIOS setup tell about boot sequence?

Richard A sweeny (rasweeny) said : #4

There is no boot sequence listed. The section is empty. It only has Boot lIst Options: Legacy or UEFI. UEFI is selcetd. There is a View button which displays nothing when clicked. There are 2 buttons: Add Boot Option and Delete Boot Option. I clicked Add Boot Option but I am not sure what to do.

Manfred Hampl (m-hampl) said : #5

I assume that you have to press "add boot option" and select the internal hard disk - if that is possible.

Richard A sweeny (rasweeny) said : #6

Yes that did it. Thank you for your help and time.