GRUB menu dissappeared after upgrade to 18.10

Asked by Krister on 2018-10-22

I just upgraded to 18.10 and have lost my GRUB menu. The machine instead boots automatically into the default kernel.

I've tried to use GRUB Customizer to restore the menu. I can choose a new default with GRUB Customizer, yet the menu will never appear.

Could you please help me restore the menu?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
Krister
Solved:
2018-10-23
Last query:
2018-10-23
Last reply:
2018-10-23

If you hold SHIFT at boot, does it show?

Manfred Hampl (m-hampl) said : #2

What is the output of the command

cat /etc/default/grub

Krister (thekswenson) said : #3

Holding Shift doesn't change anything.

Krister (thekswenson) said : #4

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT="saved"
GRUB_TIMEOUT_STYLE="hidden"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="640x480"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_SAVEDEFAULT="true"

Manfred Hampl (m-hampl) said : #5

Try the following:

Edit the grub config file with a text editor of your choice and with admin rights, e.g. with the command
sudo gedit /etc/default/grub

Change the 7th line
from
GRUB_TIMEOUT_STYLE="hidden"
to
GRUB_TIMEOUT_STYLE="menu"

Save the file, close the editor and issue the command
sudo update-grub

and finally reboot.
Do you now see the grub menu?

Krister (thekswenson) said : #6

Yes. Thank you!