package grub-common 2.02~beta2-9ubuntu1.3 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting configuration

Asked by Liliano Tagliazucchi on 2015-09-18

Every update I see this problem: help me to fix it, please!

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: grub-common 2.02~beta2-9ubuntu1.3
ProcVersionSignature: Ubuntu 3.13.0-63.103-lowlatency 3.13.11-ckt25
Uname: Linux 3.13.0-63-lowlatency x86_64
NonfreeKernelModules: wl fglrx
ApportVersion: 2.14.1-0ubuntu3.13
Architecture: amd64
Date: Fri Sep 18 08:03:34 2015
DuplicateSignature: package:grub-common:2.02~beta2-9ubuntu1.3:package is in a very bad inconsistent state; you should reinstall it before attempting configuration
ErrorMessage: package is in a very bad inconsistent state; you should reinstall it before attempting configuration
InstallationDate: Installed on 2013-10-03 (714 days ago)
InstallationMedia: Ubuntu-Studio 12.04.3 "Precise Pangolin" - Release amd64 (20130820)
InvalidGrubScript: /etc/default/grub
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-63-lowlatency root=UUID=7a66751d-befd-4e97-9f9c-eb548af236ae ro nomdmonddf nomdmonisw
RelatedPackageVersions:
 dpkg 1.17.5ubuntu5.4
 apt 1.0.1ubuntu2.10
SourcePackage: grub2
Title: package grub-common 2.02~beta2-9ubuntu1.3 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting configuration
UpgradeStatus: Upgraded to trusty on 2014-09-01 (381 days ago)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
Liliano Tagliazucchi
Solved:
2015-09-19
Last query:
2015-09-19
Last reply:
2015-09-18
Liliano Tagliazucchi (liliano) said : #1
Phillip Susi (psusi) said : #2

Try running sudo apt-get install -f.

Liliano Tagliazucchi (liliano) said : #3

Unfortunately doesn't solve my problem: I'm reporting below, what my terminal did (sorry, but my system is in Italian ...):

tagliazucchi@tagliazucchi-Aspire-5552G:~$ sudo apt-get install -f
[sudo] password for tagliazucchi:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 2 non aggiornati.
5 non completamente installati o rimossi.
È necessario scaricare 0 B/1.674 kB di archivi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
dpkg: errore nell'elaborare il pacchetto grub-common (--configure):
 il pacchetto si trova in uno stato di inconsistenza critico: è consigliato
 installarlo nuovamente prima di tentare la configurazione.
dpkg: problemi con le dipendenze impediscono la configurazione di grub2-common:
 grub2-common dipende da grub-common (= 2.02~beta2-9ubuntu1.3); comunque:
  Il pacchetto grub-common non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto grub2-common (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di grub-pc-bin:
 grub-pc-bin dipende da grub-common (= 2.02~beta2-9ubuntu1.3); comunque:
  Il pacchetto grub-common non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto grub-pc-bin (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di grub-pc:
 grub-pc dipende da grub-common; comunque:
  Il pacchetto grub-common non è ancora configurato.
 grub-pc dipende da grub2-common (= 2.02~beta2-9ubuntu1.3); comunque:
  Il pacchetto grub2-common non è ancora configurato.
 grub-pc dipende da grub-pc-bin (= 2.02~beta2-9Segnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
                                                                            Segnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
                         Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
                                 Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
                                         ubuntu1.3); comunque:
  Il pacchetto grub-pc-bin non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto grub-pc (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di grub-gfxpayload-lists:
 grub-gfxpayload-lists dipende da grub-pc (>= 1.99~20101210-1ubuntu2); comunque:
  Il pacchetto grub-pc non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto grub-gfxpayload-lists (--configure):
 problemi con le dipendenze - lasciato non configurato
Si sono verificati degli errori nell'elaborazione:
 grub-common
 grub2-common
 grub-pc-bin
 grub-pc
 grub-gfxpayload-lists
E: Sub-process /usr/bin/dpkg returned an error code (1)

Liliano Tagliazucchi (liliano) said : #4

I tried to reinstall grub-common (as I could see in my native language, into the error message ... to be honest!) with Synaptic and the problem is disappeared!

Sorry for the inconvenience!