can't boot headless PC after update version 2.02~beta2-9ubuntu1.3

Asked by hefty on 2015-07-08

Hallo,

today I updated the following packets:
grub-common (2.02~beta2-9ubuntu1.2) to 2.02~beta2-9ubuntu1.3
grub-efi-amd64 (2.02~beta2-9ubuntu1.2) to 2.02~beta2-9ubuntu1.3
grub-efi-amd64-bin (2.02~beta2-9ubuntu1.2) to 2.02~beta2-9ubuntu1.3
grub-efi-amd64-signed (1.34.3+2.02~beta2-9ubuntu1.2) to 1.34.4+2.02~beta2-9ubuntu1.3
grub2-common (2.02~beta2-9ubuntu1.2) to 2.02~beta2-9ubuntu1.3

After the update I can't boot my headless pc anymore. It hangs, so it is not possible to connect using ssh.
When I boot while a monitor is plugged-in everything works as expected. The OS and all services are starting on boot.

What is the reason for this behavior after update from version 1.2 to 1.3? How can I fix this?
Or how can I downgrade to version 1.2?

My system:
Intel x64 UEFI (secureboot disabled)
Linux Mint 17.1 Xfce (Ubuntu 14.04 LTS)

/etc/default/grub:
GRUB_DEFAULT=0
GRUB_TIMEOUT=2
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
hefty
Solved:
2015-07-09
Last query:
2015-07-09
Last reply:
2015-07-08

Mint is not supported by the Ubuntu community in any way. It's support community is entirely separate from Ubuntu's

I suggest you post on the Mint forum which is here:
http://forums.linuxmint.com/

hefty (regardless) said : #2

Ok, now I'm able to boot my pc in headless mode again.
The solution for me was to deinstall grub/grub2 and install rEFInd (http://www.rodsbooks.com/refind), a alternative Boot Manager.