dual boot error no such device found 14.04

Asked by bob test on 2014-04-20

I'm running older dell dimension 8200 with windows xp sp 3, pentium 4 2Ghz, 1Gb of memmory, and two hard drives primary 40 Gig and slave 250 Gig.

I had dual boot with grub windows XP and Ubuntu 10.10 installed using wubi, I've uninstalled Ubuntu 10.10 in Windows. And decided to try out 14.04, with live DVD, installed and reinstalled 14.04 four times,

 on boot I get " error: no such device found xxxxxxxxxxxxxxxxxx grub rescue" xxxxxxxxxxxx refers to partition on my slave 250 Gig drive that Ubuntu has created and installed 14.04.

 I gave up on Ubuntu and try to fix MBR using restore disk and that didn't work. Looked on forums found boot rescue disk utility, could not download because Ubuntu live limits download folder size, found info on upgrading grub, that didn't help, the issue seems simply that the grub and the 14.04 is installed on the drive that won't boot sdb6 instead of sda2 where XP is installed.

Now I can't get to my XP and can access Ubuntu only through live DVD which runs like molasses.

 Please Help! I need either to remove Ubuntu and grub to get access to XP or resolve this issue so I can access to dual boot.

Thank you for your help.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Last query:
2014-04-21
Last reply:
2014-04-21
bob test (bobtest400) said : #2

Thank you for you reply,
I've tried following the video but when I get to the step "sudo mount -bind /dev /mnt/dev" I get a message "mount: invalid option -- 'b' " Unlike in the video I have two hard drives installed SDA and SDB when I installed Ubuntu it was installed on sbd6. Could this be causing all my problems?
Here what I get from disk -l

/dev/sda1. 63. 64259. 32098+ de. dell utility
/dev/sda2. * 64260 . 78172289. 39054015 7 hpfs/NTFS/ex fat

Disk /dev/SDB 400.1 GB

/dev/sdb1. 63. 403990749. 2019953+ 7 hpfs/NTFS/ex fat
/dev/sdb2. 403992574. 781422591. 188715009. 5 extended
/dev/sbd5. 779331584 781422591. 1045504. 82. Linux swap / Solaris
/dev/sbd6. 403992576. 779331583. 187669504. 83. Linux

At this point I would like to just get to Window XP but my restore CD fix MBR didn't yield any results,

Please Help me to fix this mess!

A Win XP CD will allow you to drop to recovery console and install NTLDR. A Windows forum will be able to advise on that

bob test (bobtest400) said : #4

I tried Windows XP recovery console again with fixmbr worked this time. So I got back to Windows XP. But was not able to fix grub or get access to Ubuntu, which pains me to no end.

However I did find couple of things, First turning off fast boot in BIOS setup might help, Second manual partition of my primary drive would have probably solved my boot issue.

Here is a link to installation guide with manual partition explained very well and step-by-step at Tecmint.com http://www.tecmint.com/ubuntu-14-04-installation-guide/

Hopefully my experience will help somebody with similar issues.

Can you help with this problem?

Provide an answer of your own, or ask bob test for more information if necessary.

To post a message you must log in.