Crash report update-apt-xapian-index

Asked by Warren Steffen on 2014-02-22

I keep getting crashes of:
/usr/bin/update-apt-xapian-index
They just seem to be random, as if it is started by some other process.
This is Xubuntu 12.04 Is this a known problem with a fix?

wsteffen

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2014-03-06
Last query:
2014-03-06
Last reply:
2014-02-24

I suggest you report a bug

Manfred Hampl (m-hampl) said : #2

update-apt-xapian-index is a package to create a searchable index on the package inventory. There is the problem that updating the inventory index (done periodically) uses a huge amount of memory. Some people have repoted that on systems with a low amount of memory (256 MB or less) the out-of-memory emergency process has sometimes killed the apt-xapian-updater.

How much memory do you have in your system?
Are there more details available about the crashes?

Warren Steffen (wsteffen) said : #3

sysinfo shows 2771MiB
There is an extensive crash file:
ProblemType: Crash
Date: Sun Feb 23 06:20:04 2014
ExecutablePath: /usr/sbin/update-apt-xapian-index
ExecutableTimestamp: 1379099128
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/sbin/update-apt-xapian-index -q -u
ProcCwd: /var/backups
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/sh
ProcMaps:ProcStatus:
 Name: update-apt-xapi
 State: R (running)
 Tgid: 2697
 Pid: 2697
 PPid: 2484
 TracerPid: 0
 Uid: 0 0 0 0
 Gid: 0 0 0 0
 FDSize: 32
 Groups:
 VmPeak: 34256 kB
 VmSize: 33488 kB
 VmLck: 0 kB
 VmPin: 0 kB
 VmHWM: 20372 kB
 VmRSS: 19944 kB
 VmData: 13088 kB
 VmStk: 224 kB
 VmExe: 2392 kB
 VmLib: 14236 kB
 VmPTE: 60 kB
 VmSwap: 0 kB
 Threads: 1
 SigQ: 1/22061
 SigPnd: 0000000000000000
 ShdPnd: 0000000000000000
 SigBlk: 0000000000000000
 SigIgn: 0000000001001000
 SigCgt: 0000000180000002
 CapInh: 0000000000000000
 CapPrm: ffffffffffffffff
 CapEff: ffffffffffffffff
 CapBnd: ffffffffffffffff
 Cpus_allowed: 3f
 Cpus_allowed_list: 0-5
 Mems_allowed: 1
 Mems_allowed_list: 0
 voluntary_ctxt_switches: 2823
 nonvoluntary_ctxt_switches: 88
PythonArgs: ['/usr/sbin/update-apt-xapian-index', '-q', '-u']
Traceback:
 Traceback (most recent call last):
   File "/usr/sbin/update-apt-xapian-index", line 101, in <module>
     if not indexer.setupIndexing(force=opts.force, system=opts.pkgfile is None):
   File "/usr/lib/python2.7/dist-packages/axi/indexer.py", line 513, in setupIndexing
     addon.obj.init(dict(values=self.values), self.progress)
   File "/usr/share/apt-xapian-index/plugins/cataloged_time.py", line 72, in init
     self._package_cataloged_time = cPickle.load(open(self._packages_cataloged_file))
 ValueError: insecure string pickle
UserGroups:

(procmaps not included)
      |
      |

Best Manfred Hampl (m-hampl) said : #4

You might try the following part of step 9 in https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure

sudo rm /usr/lib/python*/dist-packages/__pycache__/*pyc
sudo apt-get install --reinstall python3-gi
rm -rf ~/.cache/update-manager-core
sudo rm /var/lib/apt-xapian-index/cataloged_times.p
sudo rm /var/lib/apt-xapian-index/values
sudo update-apt-xapian-index --verbose --force
sudo update-apt-xapian-index --force

Warren Steffen (wsteffen) said : #5

Thanks Manfred Hampl, that solved my question.

Warren Steffen (wsteffen) said : #6

The first command resulted in "not found" or something like that. But I have not had the crash for over a week now,
so I think it is fixed. Thank you!