Grub boot menu keys has suddenly changed, can't use arrow keys

Asked by Gabor Vas on 2013-09-25

I'm using Kubuntu 12.04, grub 1.99 on an Acer Aspire 5750 laptop, with a multiboot system. Suddenly, I realized I can't select boot option with arrow keys but I can use "p" for previous, "n" for next, and "e" for last option. Extarnal usb keyboard gives the same exact result. I updated grub and checked all computer for malwares, still negative result, no effects at all.
If i boot kubuntu, any kernel version, my keyboard functions properly later on, I can type password in, I can change keyboard layout with ALt+Caps, etc. But if I boot win7, I can't type my password in, not even with on-screen or external keyboard. However, pressing backspace fills with certain (hidden) characters the password field.
I assume a loaded kubuntu kernel uses different drivers for keyboards, but why grub and win7 fails to use theirs?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
Thomas Krüger
Solved:
2013-09-26
Last query:
2013-09-26
Last reply:
2013-09-25
Best Thomas Krüger (thkrueger) said : #1

The key combinations for Grub are Ctrl+N and Ctrl+P, not N and P. Is it possible your Ctrl key it stuck?

Gabor Vas (cognac-gamma) said : #2

Well, it is possible as my left control had not worked for ages. The problem has appeared much later. But with my right Control I can handle all key combinations in kubuntu.
If the case is stucked left Control, is there any temporary solution until I have my keyboard repaired? Or how can I ensure that's the case?

Try setting the USB to legacy mode in BIOS

Gabor Vas (cognac-gamma) said : #4

Thanks Thomas Krüger, that solved my question.

Gabor Vas (cognac-gamma) said : #5

Thanks all, it seems to be imposiible mission to get to advanced BIOS