Ubuntu 12.04.1 hangs after GRUB

Asked by vis on 2013-02-17

I had Ubuntu 10.04 LTS. I removed this and installed Ubuntu 12.04.1 LTS clean with the DVD.
The installation finished successfully. The only thing I had to do during the installation, is set nomodeset and no1apic, otherwise my laptop would hang. With these checked, it went fine.

Now, when I start up the laptop, I come to the GRUB. I can choose ubuntu, but then I see a purple screen and the computer hangs (freezes). When I choose rcovery mode, the computer also hangs. I tried CTRL-ALT-DEL, but the computer does not respond. The only thing I can do is turn the laptop completely off and start over again (with the same result).

Can anybody help me?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Last query:
2013-02-17
Last reply:
2013-02-18
Ubfan (ubfan1) said : #1

At the grub screen, type e to edit the boot commands (instructions are at the bottom of the screen). Add your nomodeset and nolapic to the linux line after the "quiet splash" words. Then control X to boot. To make this change permanent, edit the changes into file /etc/default/grub, adding them to the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". Then run
  sudo update-grub

vis (edanvisser) said : #2

OK, I will try that.
Just a question:
what does nomodeset and nolapic do?
do I have a disadvantage if I add this?
Does this have to do with the graphical card? If yes, does this mean that I will have a "less pretty" ubuntu?

What GPU does the system use?
Does it have a make and model?

Ubfan (ubfan1) said : #4

The nomodeset is releated to graphics, and may result in a lower screen resolution than is possible with proprietary drivers, but on a fresh install, you may not even have those drivers, so it may be useful until other drivers are installed by your actions.
the nolapic changes the way local interrupts are handled, to avoid some bios problems -- google for more info.

It will also allow you to install updates which may fix the bug.

vis (edanvisser) said : #6

Ok.
I have a geForce graphical card. I was able to install the correct driver and install the updates.
Can I remove the nomodeset and nolapic?

Add the boot option:

nouveau.blacklist=1

Can you help with this problem?

Provide an answer of your own, or ask vis for more information if necessary.

To post a message you must log in.