Dual boot Windows XP & Ubuntu 12.04 . I cannot see Windows XP entry on grub menu. (Boot Repair info inlcuded)

Asked by Niall David McCathie on 2013-01-31

I carried out a dual boot install alongside WP.

When I re-boot, whatever I do I only get Ubuntu - without a chance to select XP

At the end I received this URL : http://paste.ubuntu.com/1589549/

The file seems to have all the relevant data - I just DO NOT know how to make the necessary connection. In case the file does not say so, I have two Hard discs.

Your help would be much appreciated

Niall

PS I have dual boot with XP working fine on my laptop

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2013-02-12
Last query:
2013-02-12
Last reply:
2013-02-08

How did you install Ubuntu? Is it a Wubi install or did you resize your NTFS to make room for the Ubuntu install?

Thanks

N1ck 7h0m4d4k15 (nicktux) said : #2

I'm not an expert , but I cannot see any weird thing in boot-repair info. I can see that all Operating Systems included in grub menu.

At your description you said
"whatever I do I only get Ubuntu - without a chance to select XP"

so you have not a Windows XP entry at grub menu at all ?

I changed your title accordingly , but if you can see the Windows XP entry but when you select is not boot , then is another problem , so please clarify this.

Thanks

To nick-athens30 : When I re-boot the computer I do not see the Ubuntu Grub "choose an operating system"menu screen at all - it goes straight to Ubuntu 12.04 LST

To andrew-woodhead666: I downloaded the 12.04 LST .iso file which was then burnt to a CD-R using Nero 7.
The installer dealt with making an extra partition (it was all one NFTS partition before)

I hope this extra information will allow you to help me

Regards

Niall

If you run:

sudo update-grub

What is output?

To: andrew-woodhead666:

When I entered "sudo update-grub", the follwing was output:

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.2.0-36-generic-pae
Found initrd image: /boot/initrd.img-3.2.0-36-generic-pae
Found linux image: /boot/vmlinuz-3.2.0-29-generic-pae
Found initrd image: /boot/initrd.img-3.2.0-29-generic-pae
Found memtest86+ image: /boot/memtest86+.bin
Found Microsoft Windows XP Professional on /dev/sda1
done

Niall

And what is the output of:

uname -a

Thanks

Hi

niall@niall-desktop:~$ uname -a
Linux niall-desktop 3.2.0-36-generic-pae #57-Ubuntu SMP Tue Jan 8 22:01:06 UTC 2013 i686 athlon i386 GNU/Linux
niall@niall-desktop:~$

N1ck 7h0m4d4k15 (nicktux) said : #8

When power on your PC hold down [Shift] key on your keyboard until grub menu appears.

sudo apt-get --purge remove linux-image-3.2.0-29-generic-pae

NickTH: This does not work (see below)

actionparsnip: This cleared out some stuff but I still cannot get Windows, cannot get the Grub opening screen

General Points:

A) When I re-boot, my screen is blank and then I get:
a) NO SIGNAL
b) OUT OF RANGE
c) NO SIGNAL
d) A full screen picture which is tells me which F-Keys to press to change the boot sequence; this is not a simple text screen it is a proper picture with ASROCK

B) I have looked around and have now got grub installed. I can get the "grub>" prompt up

C) I am considering a complete re-install of Ubuntu 12.40 LTS - but will wait to see if my new information above shows what I've none wrong and anyone gives me the commands I need to fix it (I think I'm within a command line or 2 of success!

Niall

SORRY! The sequence in A) above should be:
a) Boot Screen:
file:///tmp/photo.JPG
b) OUT OF RANGE
C) Ubuntu starts (no Grub menu choices)

Niall

Arif Budiman (arifpedia) said : #12

1. Remove old kernel: sudo apt-get --purge remove linux-image-3.2.0-29-generic-pae
2. Update grub : sudo update-grub
3. Reboot

In desperation I have done a complete re-install of Ubuntu 12.04 LST.

The installation was fine - no faults reported

During install the software reported that these was a Windows XP Pro installation and I agreed to install U12.04LST alongside it as a dual boot system

I cannot still boot Windows - how can I gain access to the Windows data - prinipally my "My Documents" folder?

Have I fu**ed my Windows OS and thereby all my data?

VERY GLOOMY TODAY!

Niall McCathie

Your backups will maintain data integrity.

N1ck 7h0m4d4k15 (nicktux) said : #15

Try to use this software:
https://help.ubuntu.com/community/Boot-Repair#A2nd_option_:_install_Boot-Repair_in_Ubuntu

Read the instructions on second option. You will need to First boot from the Live Media you have. The media you installed Ubuntu.

If no join , you can access the Windows partition data from nautilus file manager.

Click on Dash (Ubuntu Icon first in side Launcher) and write : nautilus

Open it and see the list on the left , it must have something like "225GB partition" , depends on the size of Windows partition !

Click to mount it and the search and find the important documents and copy them to a safe location.

Thanks

Thanks nick-athens30 - you are very patient!

Your suggestion has not worked - but I think I must be within a few command lines of success.

This time I have recorded each step of what I did when I :
a) Re-installed U 12.04 LST
b) Downloaded and ran boot-repair
cc) Downloaded the boot-repair log from paste-ubuntu

I can up-load my LibreOffice file with all the data if that would help

It all seems to hinge on these 2 lines:

You can now reboot your computer.
Please do not forget to make your BIOS boot on sdb (123GB) disk!

- as I cannot find the "sdb (128GB) disk"

Cheers

Niall

Best N1ck 7h0m4d4k15 (nicktux) said : #17

If the grub installed on sdb , the sdb is the Second driver in your PC.

Try to boot into BIOS configuration page and change the boot order device , set the second Driver - First.
Then press F10 to save and boot with new configuration.

See an example of change the boot order - BIOS here:
http://helpdeskgeek.com/how-to/change-boot-order-xp-vista/

Maybe your BIOS is a little different than the BIOS in above example , but is almost the same.

Thanks

Thanks to everyone's help I have succeeded!

The most helpful information was to un-comment the line in grub that sets the screen setting and also changing the Time Outs. Without doing this I was not seeing the grub screen - or not for long enough

Then I did a boot-repair
Then upgraded to Grub2 (or is it grub-pc?) - still not sure
Re-set the Screen and T/O settings
EUREKA!

System now boots to the grub screen and will boot to Ununtu or Windows XP

Thanks to you all for your patience with a beginner

jayakrishna (jayakrishna915) said : #19

hi Niall,

I am also facing the same problem, grub menu showing error/input not supported/ blank screens. can u guide me on this.
where did u get un-commented the line in grub that sets the screen setting and also changing the Time Outs.

Tell the other required comands also.

but luckily i am able to login to my other OS (XP). by pressing down arraow buton 4 times then pressing enter key.

Thanks