raring grub-pc does not allow choice of stock kernel vs mainline kernel

Asked by jerrylamos on 2013-01-17

Grub2 can't choose kernels
Grub2 does not allow choice of "mainline kernel" vs. stock Ubuntu kernel.

In:

ttps://wiki.ubuntu.com/Kernel/MainlineBuilds?action=show&redirect=KernelMainline Builds

it says:

"The mainline kernels have their own ABI namespace so they install side by side with the stock Ubuntu kernels (each kernel has a separate directory under /lib/modules/VERSION for example). This means that you can keep several mainline and Ubuntu stock kernels installed at the same time and select the one you need from the GRUB boot menu."

Here's from /boot:

Jan 9 22:44 config-3.8.0-030800rc3-generic
Jan 15 16:01 config-3.8.0-0-generic

Now in fact /boot/grub/grub.cfg does show entries for both kernels, but the Grub2 menu on boot does not show the stock Ubuntu kernel or allow choosing it.

How do I get Grub2 boot menu to display all the kernels that are in grub.cfg?

Thanks....btw, amd64

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: grub-pc 2.00-10ubuntu1
Uname: Linux 3.8.0-030800rc3-generic x86_64
ApportVersion: 2.8-0ubuntu1
Architecture: amd64
Date: Thu Jan 17 15:58:39 2013
InstallationDate: Installed on 2012-12-14 (34 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20121213)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
jerrylamos
Solved:
2013-01-17
Last query:
2013-01-17
Last reply:
2013-01-17
jerrylamos (jerrylamos) said : #1
Phillip Susi (psusi) said : #2

The additional kernels show up when you chose the option for other versions.

jerrylamos (jerrylamos) said : #3

I had looked at the Advanced Options which for some time hasn't solved anything for me.

This time it did give me four options

upstream kernel
upstream kernel recovery mode
stock kernel
stock kernel recovery mode

So I picked stock kernel which worked.

Thanks for the pointer. I wouldn't have guessed it from the grub2 menu entry title.