usb-keyboard doesn't work in GRUB menu.

Asked by daniel CURTIS on 2013-01-17

Hi

A few days ago I've noticed, that the usb-keyboard does not work in GRUB2 menu. I can not change any position using the keyboard buttons. I can not use the Enter button to boot selected OS. Pressing 'e', 'a', 'c' options/buttons also not working. I can not do anything, but I have to notice, that the usb-keyboard works okay in a graphical environment (XFCE).

I had to change the usb-keyboard to the standard PS/2 keyborad. With this type of keyboard, everything started to work - I can edit the command before booting or modify the kernel arguments etc. Generally, I can do everything. Should I report a bug?

Best regards!

,----[ NOTE/WARNING: ]
| Question: https://answers.launchpad.net/ubuntu/+source/grub2/+question/214341
| Solution: open BIOS configuration page and Enable USB-Legacy support.
`----

I've noticed a similar question about a usb-keyboard and GRUB menu. At this moment I can not verify this solution. I check it out within a few days. I hope, that this solution, also will help in my case.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2013-02-05
Last query:
2013-02-05
Last reply:
2013-01-18

Its needed in Windows sometimes too. You could report a bug to document the fact that it's needed

daniel CURTIS (anoda) said : #2

Hi Andrew,

Linux is the only operating system on this computer. There is no Windows. If I remember correctly, I have had a similar issue with Wheezy. Firstly: I will try the solution described in question #214341. Mr Andrew - If nothing changes, then I have to report a bug, right?

Best regards!

Best N1ck 7h0m4d4k15 (nicktux) said : #3

Boot into BIOS configuration page and search for "USb Legacy" support and enable it.

Thanks

daniel CURTIS (anoda) said : #4

Hi NikTh. Your advice solved the problem. After enabling 'USB Legacy', I can enter to the GRUB with pressing shift key. I would like to share with people, that have a similar problem where I found this option - USB Legacy:

,----[ Enter BIOS ]
| Integrated Peripherals -->
| USB Device Setting -->
| USB Keyborad Function (Legacy support of USB Keyboard)
`----

daniel CURTIS (anoda) said : #5

Thanks NikTh, that solved my question.

Vasya Pupkin (shadowlmd) said : #6

And what if I don't have such option in BIOS?