Ubuntu 12.04 , 64bit always showing grub menu

Asked by Sukhendu Ghosal on 2013-01-13

Ubuntu 12.04 , 64bit always showing grub menu . This was not happen before . How to reset it to default .I dont want to see this every time. Only ubuntu 12.04 installed.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Last query:
2013-01-14
Last reply:
2013-01-14

What is the output of:

cat /etc/default/grub

Thanks

N1ck 7h0m4d4k15 (nicktux) said : #2

Probably you have more than one kernels installed. Grub menu show up to give you the option to boot from another kernel. (Previous Linux versions).

Try to remove the old kernels and test again.

A quick and easy way to remove old kernels is via "janitor" of Ubuntu-Tweak program.

Installation of Ubuntu Tweak via terminal.

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Thanks

sukhendu@1440 ~ $ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
sukhendu@1440 ~ $

@ NikTh (nick-athens30)

How can I remove old kernels , without installing tweak tool ? I have updated my Kernel ,so this may be a cause.

N1ck 7h0m4d4k15 (nicktux) said : #5

You mean from terminal ?

sudo apt-get purge linux-image-xxxx-xxxx

where xxxxx is the number of the kernel you want to remove.

For example

sudo apt-get purge linux-image-3.2.0-29-generic

If you want help for this , then give the results of below command

ls /boot/

Thanks

daniel CURTIS (anoda) said : #6

Hi, please note, that 'linux-headers' packages also should be removed (e.g. 'linux-headers-3.2.0-29-generic').

Can you help with this problem?

Provide an answer of your own, or ask Sukhendu Ghosal for more information if necessary.

To post a message you must log in.