grub installation problems with GPT and UEFI (Ubuntu 12.04)

Asked by gabry78 on 2012-11-10

Hello,

I’m a Ubuntu user since 2008. I’ve buy a new computer, a Asus Zenbook Interl i7 with GPT partition modality UEFI, Windows 7 as default o.s. (unfortunately). Hybrid HDD with SSD
I’ve tried to install Ubuntu 12.04.1 (in dual boot with win), but Grub doesn’t run. Here what I’ve done:
- I’ve created USB Ubuntu boot disk and I’ve ran in not-UEFI modality (bios can run USB in UEFI modality but USB Ubuntu boot disk disk won’t to run in this modality)
- Installed root on SSD (sdb1); home and swap on HDD

Automatic installation can’t install grub in every logical partition (eg sda1, sda2, etc), so I’ve tried it in manual modality (reading a lot of forums…):
- I’ve created a partition ext2 with 2mb of free space, flagged as bios_grub (with gparted)
- Partitions are those:
* HDD
• Sda1: [EFI] FAT32 Windows starter (boot)
• Sda 2: NTFS Windows main partition (C:)
• Sda3: EXT2 (bios_grub) 2mb
• Sda5: EXT4 /home
• Sda6: NTFS Windows second partition (used for data)
• Sda7: Windows resume partition

* SSD
• Sdb1: EXT4 /

- I’ve executed, from a Ubuntu usb boot disk, as chroot on sdb1, grub-install /dev/sda (I’ve also tried /dev/sda1). Screen said: grub installed, no errors

…but, once rebooted, screen shows starting Windows, but no grub appears on it. Why?

Thanks for your support

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2012-11-11
Last query:
2012-11-11
Last reply:
2012-11-10
Best N1ck 7h0m4d4k15 (nicktux) said : #1

I haven't UEFI ,
but your partitioning schema is a little wrong.(weird is a better word). Inside /home partition exist configuration files of some programs . You should install Ubuntu in SSD as one part. /root and /home in same SSD in order to have good (SSD) speed.

Also I think you have to create a separate /boot partition (in case of UEFI) for better results and try to use this automatic tool => https://help.ubuntu.com/community/Boot-Repair#A2nd_option_:_install_Boot-Repair_in_Ubuntu

to correct your problem.

Thanks

gabry78 (gabriele-ciuti) said : #2

Thanks for your help!

I was skeptical about boot-repair, but I've executed it and... the problems are solved !
This program is very very excellent! Of course, I've understood only some things about EFI installation but the program explain all actions and it creates a final report about what it had done.

However I've understand grub was wrong, in fact, boot-grub uninstalled it and installed a grub-efi version

Now I can run ubuntu without problems.

thanks

gabry78 (gabriele-ciuti) said : #3

Thanks NikTh, that solved my question.