ubuntu 12.10 fails to boot with "Could not stat the resume file"

Asked by Robert Hogg on 2012-11-05

I had the same problem when I tried to upgrade from version 11.4 to 11.10. I have a large disk partitioned with Windows first, 11.4, swap, 12.10, and another swap partition. The error message mentions /dev/sdb4 as the resume device file which is the second of the two swap partitions. Is this a problem with having multiple swap partitions on the same disk?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
Robert Hogg
Solved:
2012-11-06
Last query:
2012-11-06
Last reply:
2012-11-05

You should only have one, only one can be used. If you have multiple Linux (or BSD) installs, they can use the same swap space.

Robert Hogg (hoggsoft) said : #2

I deleted the second swap partition and extended the install destination partition and selected format when I did the install. Now the error message is "error: no such device...". Running version 12.10 from the CD works OK. I am now thinking that there is a problem with the boot loader. How can you see the entry details of the boot options?

Robert Hogg (hoggsoft) said : #3

Yes my problem is the new grub.cfg is not being applied to the boot sector or whatever. I need to find out why the new config is not being written to where ever it should go.

Robert Hogg (hoggsoft) said : #4

Regenerated the grub.cfg file which correctly found the new version and I am now able to boot up from it.