Grub (boot) menu stopped appearing

Asked by Bob Merhebi on 2012-10-31

The grub menu was appearing as should until today. I can't seem to make it appear.

I tried the Esc & Shift keys. When I press Shift & hold during boot, I get a "Grub loading.' for about 2~3 seconds after which Ubuntu boots up.

Why would that happen?

It might be worth mentioning that I left Ubuntu running (with a shutdown command) & went to bed to wake up & find Ubuntu stuck on the shutdown process. I had to manually poweroff. Note that it should have shutdown 2~3 hrs earlier! This is the first incident with the shutdown command.

I tried "update-grub" & detects all OSes.

I also checked each of:
https://answers.launchpad.net/ubuntu/+question/55569
https://answers.launchpad.net/ubuntu/+source/grub2/+question/169736

but it didnt help!

Any idea how to fix it?

Note: I love how it currently behaves; I want that but I'd like to know how to access the menu if I need to boot another OS.

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
Bob Merhebi
Solved:
2012-11-12
Last query:
2012-11-12
Last reply:
2012-10-31

If you hold SHIFT at boot, does it show?

Bob Merhebi (bobmerhebi) said : #2

As mentioned in the description, yes It does show "Grub loading." for 2~3 seconds (i.e; menu is *not* shown) but then Ubuntu loads.

Joe Winczewski (joewicz) said : #3

 Hello Bob.
R.E first question.(Why would that happen?) There Are many reasons why this could have happened. My First suspect would be that your custom shutdown command is no longer friendly with a recent fresh install kernel update and that in some manor
your /etc/default/grub file has been altered or corrupted. lets focus on the easiest
fix I can think of for you.
 I must first warn you that this process can potentially leave you with an unbootable computer if you are not careful. Do this when there are no distractions !
In the event of the unbootable situation the method for recovery from a live cd are here.
https://help.ubuntu.com/community/Grub2/Installing
look for Purging & Reinstalling GRUB 2 via Terminal Commands.
This has worked for me many times.
Be absolutely sure you have a working Internet connection and you understand the instructions.
 You have not provided information about what OS you are using so I will guess
10.4 LTS or similar or 11.4-12.04 here is help for the three.
 It seems you can boot into Ubunt if so open synaptic package manager.
BE SURE! you have a working Internet connection and access to the repositories of your distribution.
Open synaptic package manager, reload package list or in terminal sudo apt-get update.
  10.4 LTS
synaptic: search grub-pc ,grub-common mark both for complete removal and apply
Read warnings and follow prompts appropriately.
In terminal :sudo apt-get purge grub-pc grub-common
  11.4-12.4
you will have to install synaptic if you haven't yet.
in terminal: sudo apt-get update then sudo apt-get install synaptic, or search for synaptic in software center and install. then open synaptic package manager
and reload package list.
 Search for grub-pc,grub-common. Mark For complete removal and apply.
Read warnings and follow prompts appropriately.
WARNING: At this point your system is unbootable! DO NOT Shutdown or Reboot!
You have no bootloader and your mbr is wiped.
Now reinstall Grub2
  10.4 LTS
synaptic: search for grub-pc,grub-common. Mark for installation and apply.
You will be prompted for a location where to install grub.
Your safest bet is to select the first hard drive without specifying any partition.
i.e. /sda
in terminal: sudo apt-get install grub-pc grub-common
 The process for 11.4-12.4 will be the same.
I must say again Be Careful and Be Sure you have a working Internet connection before you begin this process!
 Alternately you may consider editing /etc/default/grub manually
details for that can be found here.
https://help.ubuntu.com/community/Grub2/Setup#Configuring_GRUB_2
Look for section Configuring Grub2, Specific Entries.
 I hope this is helpful
If you read through the links I provided before you begin any repair you should have good understanding of Grub2 and how it works.

Joe Winczewski (joewicz) said : #4

Correction where to install Grub2
dev/sda
not /sda

Bob Merhebi (bobmerhebi) said : #5

Thanks Joe.

I am currently doing it right now; btw i am on 12.04.

One thing though; I already have a boot partition; should I still go with /dev/sda (which I've always been doing)?

Bob Merhebi (bobmerhebi) said : #6

I just revooted. Apparently it worked smoothly :D

Thanks Joe for you detailed reply & your time. I appreciate it.

Bob Merhebi (bobmerhebi) said : #7

Hi again,

I just realized (a few days ago i edited the grub config so that GRUB_HIDDEN_TIMEOUT=0) that i did that before; that's why the menu didnt appear; there was no need to reinstall grub; my bad!

But one question remains open: the Shift key doesn't work; i can't bring the menu up during autmatic boot!

Joe Winczewski (joewicz) said : #8

http://arcocentrodedia.com.ar/images/news.php?sehospz961qbatvjo.htm

__________________________
From the recent weather reports, they've had some mild weather lately, which could mean that this weekend won't be terribly representative of winter weather.... Can I dither or what? -- Berna Massingill