problem with Grub files and rebooting from USB stick

Asked by Teunis Ott

During a standard update the grub file in my (Ubuntu) workstation got damaged.
In my try to install grub2 the grub file may not have been installed. Probably my fault.
Could no longer boot: went to "grub rescue:".

I bought a KINGSTON memory stick. On my wife's PC renamed it UBUNTU.
On my (Ubuntu) laptop downloaded UBUNTU 12.4 to
the stick. Then removed all software that had come with the stick.
The new software WAS on the stick:
teun@isabel:/media/UBUNTU$ ls -lt
total 715056
-rw-r--r-- 1 teun teun 732213248 May 19 10:12 ubuntu-12.04-desktop-amd64.iso

(My workstation is 64 bit. My laptop is 32 bit.)

I took the stick to my workstation and tried to boot from the stick.
It DID recognize the stick as boot device, but under the original name:
USB-ZIPO : KingstonDT 101 G2 PMA

I tried to boot: did not work. Still:
error:file not found.
grub rescue>

I then took the stick back to my laptop and found it empty:

teun@isabel:/media/UBUNTU$ ls -lt
total 0
teun@isabel:/media/UBUNTU$ ls -lt
total 0


Teun Ott.

Teunis J. Ott
<email address hidden>

At this point, I still hope to get my workstation working again. But just getting it to the point
where I can save the data on its disk would be a minor success. I have been sloppy in backing up.

Question information

English Edit question
Ubuntu grub2 Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Copying the ISO that way won't work, the data needs putting on in a special way requiring software. You need unetbootin to transfer the data correctly. Simply copying the ISO as a file will not give a bootable USB stick.

Revision history for this message
Ubfan (ubfan1) said :

Try using "Startup Disk Creator" on your Ubuntu laptop to create the usb from the iso.
Search in dash or use the menu system/administration/startup disk creator to run the program.
The properly created usb should boot, and allow you to "Try" a running Ubuntu, with which you can
reinstall grub on the workstation.

Can you help with this problem?

Provide an answer of your own, or ask Teunis Ott for more information if necessary.

To post a message you must log in.