Ubuntu

Grub rescue - wubi installed

Asked by spear25 on 2012-05-13

I'm new to Linux, Appreciate if anyone could resolve this issue, Thanks!!

My system use Windows vista x86 32 bit.

After installing Ubuntu, the only screen I get after initialization is grub rescue.

Installed using Wubi; error: unknown filesystem > grub rescue > ls
(hd0) (hd0,msdos8) (hdo,msdos7) (hd0,msdos6) (hd0,msdos5) (hd0,msdos4) (hd0,msdos2) (hd0,msdos1).

tried the troubleshooting steps from

https://help.ubuntu.com/community/Grub2#Rescue_Mode_.28.27.27grub_rescue.3E.27.27.29_Booting

error from insmod normal > unknown filesystem

input this command as advised on site: insmod (hd0,1)/usr/lib/grub/i386-pc/normal.mod, hd0,1 to 6 were used as I didn't find the file > got error unknown file system

2nd Stage

Reinstalling grub from flash drive - commands used ( followed by a YouTube video)

fdisk -l

dev/sda1 - Hidden NTFS WinRe
dev/sda2 - HPFS/NTFS/exFat
dev/sda3 - W95 Ext'd (LBA)
dev/sda4 - compaq Diagnostics
dev/sda5 - HPFS/NTFS/exFat
dev/sda6 - Linux swap / Solaris - 5859328
dev/sda7 - Linux - 14647296
dev/sda8 - Linux - 23113728

sudo mount /dev/sda7 /mnt

sudo mount /dev/sda7 /mnt/boot

sudo mount --bind /dev /mnt/dev/

sudo chroot /mnt

sudo grub-install /dev/sda
sudo: unable to resolve host ubuntu
Installation finished. No error reported

sudo umount /mnt/dev
sudo umount /mnt/boot
sudo umount /mnt

Atlast it didnt work> back to square one >

error:file not found
grub rescue>-

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
spear25
Solved:
2012-05-15
Last query:
2012-05-15
Last reply:
2012-05-13
Barry Drake (b-drake) said : #1

Be very careful - you could easily trash your Windows installation. First, try booting into the live-DVD (not using wubi). You will get an option to 'Try Ubuntu'. This will not install anything so go for it. See if you can use Ubuntu fro the DVD, and check that all your hardware works. When you are satisfied, you might want to try a native installation of Ubuntu rather than a wubi one. The wubi installation has installed itself over Windows like a Windows application, and can be removed under Windows like any other Windows installed app. Having said all that, I'm not actually sure of anything where Windows Vista is concerned.

It does look from the above as though Vista cunningly uses a separate boot partition - maybe to cause us problems. Look at the following:

Re-install grub from live-CD
sudo -i
mount /dev/sda2 /mnt #assuming that Ubuntu is on sda2 - check with gparted
mount /dev/sda3 /mnt/boot #skip this one if there is not have a separate /boot partition
grub-install --root-directory=/mnt/ /dev/sda

then do update-grub

Barry Drake (b-drake) said : #2

Add this: the Compaq strange partitioning will cause a problem. I'm guessing totally. Maybe /dev/sda1 is the boot partition. The You Tube video references a standard installation. Compaq has ensured that yours is not. Use the DVD to look around the partitions you have and try to work out what they are.

spear25 (spartanz250) said : #3

Thanks for your post Barry.

Eventually I got into windows - using supergrub. It's a great software when someone is stuck without knowing what to do.

I will remove wubi first and will continue installing ubuntu through CD.

sda2 is my windows partition sda1 and sda4 (EISA configuration).
sda6 is Linux partition.