Ubuntu

USB ports not working

Asked by Rick Allgier on 2012-04-20

I installed Ubuntu Linux on a Compaq computer for a friend and the USB mouse wasn't working. I managed the entire installation using just the keyboard, which connects via PS/2 port. After the installation, the USB mouse still doesn't work. Unfortunately, I can't paste the lsusb or dmesg info to this question, as the only way I can connect to the internet is via USB port, which is exactly the problem.

Additional info:
I have tried 2 different USB mice on this computer as well as a flash drive, and it won't detect any of them. All 3 devices work just fine on my laptop, which has Windows Vista(not by choice).

I'm not sure if it's something to do with the drivers, but when I try to open Additional Drivers, I get an error message that says "Downloading package indexes failed, please check your network status. Most drivers will not be available." I could just be looking in the wrong place to check driver data.

The GRUB menu also doesn't work for some reason. When I boot up the computer, holding shift does nothing, and even though it gives the option of pressing F11 to launch System Recovery, it won't read that either. It will only allow me into the Boot Menu and Settings.

I also checked to make sure that the USB Support was checked in the Settings area of the BIOS menus.

Any suggestions?

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-20
Last reply:
2012-05-06

Try setting the USB to legacy mode in bios.

Rick Allgier (rickallgier) said : #2

As I stated at the end of my problem, I have already enabled USB Legacy Support Mode. Please read the entire question before offering a solution.

Rick Allgier (rickallgier) said : #3

New information:

After running a few more tests on the computer, I believe that the USB drivers may have been deleted by the owner's son(who attempted to fix her computer and ended up needing me to install a whole new OS because of it).

Is it possible to download USB 2.0 drivers via CD using Ubuntu?

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.