Error :unknown filesystem grub rescue>

Asked by philliard206

When I turn on the computer I get a blank screen with just the following:
 error: unknown filesystem
 grub rescue>

Question information

English Edit question
Ubuntu grub2 Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Tomodachi (tomodachi) said :

It would seem you have a problem with your filesystem or boot-loader
If the question you ask is what to do.

The answer would be.

Try booting of a ubuntu live-cd.
From there you can run a filesystemcheck. Maybe that will be enough.
If not you might need to re-install / repair grub from the ubutu live-cd

maybe this can be of more help

Revision history for this message
Best delance (olivier-delance) said :

As explained Tomodachi, you have to reinstall Grub2:

Revision history for this message
philliard206 (philliard206) said :

That solved the problem thank you but I have one more question, with the new 11.10 is it possible to still use ubuntu classic.

Revision history for this message
philliard206 (philliard206) said :

Thanks delance, that solved my question.

Revision history for this message
delance (olivier-delance) said :

In theory, yes. You have to install gnome-fallback-session, but I plan to use more radical solution as I'm not happy of gnome-fallback-session (and of Unity for software development).

Revision history for this message
Eliah Kagan (degeneracypressure) said :

The package for GNOME Classic (also called GNOME Fallback) is called gnome-session-fallback, and it can be installed in the Software Center.

However, this is not the same as Ubuntu Classic. It is a similar interface, but it is not the exactly the same.

After you install it, you can select "GNOME Classic" or "GNOME Classic (no effects)" as your session type menu. To bring up this menu, click the gear icon. This is when you are at the login screen.

Other options for interfaces include GNOME 3 with the GNOME Shell rather than Unity (see; install gnome-shell and select "GNOME"), Xfce (see and; install xubuntu-desktop and select Xubuntu), LXDE (see and; install lubuntu-desktop and select Lubuntu), and KDE (see and; install kubuntu-desktop and select Kubuntu).

Revision history for this message
Josev (jking44) said :

I installed Ubuntu 12.04 as a dual boot with windows Vista, now i get black screen with
error: unknown filesystem
  grub rescue>

i have tried booting from Ubuntu disk, and also from windows disk, and nothing happens except original black screen.

i cannot get into any file systems, and all the searches i have done so far are getting me nowhere.

any advice other than throwing my laptop out of the window ?

Revision history for this message
Barry Drake (b-drake) said :

Josev .... I think you should have started a new question here. If you can't boot from a CD it would be a hardware problem. What computer are you using? How have you set it to boot from a CD? How did you originally install Ubuntu (if it was with Windows runni9ng, then this is your very big problem). Please give exact information on what happened, what the messages were (EXACTLY) and what you see during the boot process.

Revision history for this message
Josev (jking44) said :

Hi Barry, good of you to get back to me......

ok, i appreciate what you say about a new question, but i thought it part and parcel of what was beging discussed here, my appologies to all if its not.

after downloading ubuntu 12.4, i burnt it to a cd, then, put disk into laptop, followed the instructions to create a 2nd partition, had the laptop reboot, and start the install on the 2nd partition. i managed to get everything up and running, even installed a couple of programs, including (Wine) so i could run a windows program on Ubuntu.

powered the laptop down while i went to bed, this morning, i just got black screen saying:
error: unknown filesystem
   grub rescue>

i tried putting Ubuntu cd back into the drive and booting from that, but it doesnt want to know, and did the same thing with the windows cd also.

just keeps coming up with the same message:
error: unknown filesystem
   grub rescue>