Failed to load after 11.04 install

Asked by rkcarney on 2011-09-17

I have Windows XP sp3 loaded and wanted to install 11.04, onto an HDD that already had an Ubuntu OS installed. After the initial installation had gone successfully at the re-boot an instant failure and left with the grub rescue command. I have been unable to get passed this and am reduced to running my computer from the 'live CD'. What can I do to restore my system?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Solved by:
delance
Solved:
2011-09-21
Last query:
2011-09-21
Last reply:
2011-09-20

Boot to liveCD and you can reinstate grub2 from there

rkcarney (rkcarney-uwclub) said : #3

Sorry about delay in returning, but have visitors staying as well as a sick computer!

to actionparsnip, thanks for the info but have tried reloading from the Live CD twice now once with a 9.04 distro and then with the 11.04 distro, both attempts got me nowhere and left me in the gru rescue command as before. Any thoughts on how to revive the Grub2 programme.

to delance, thanks for the info but had already been thrugh that page of the Ubuntu help and indeed have it loaded at present. However from this versiion of grub rescue command line that I engender the command normal has no function, exit is not recognised and ls gives the following result:

(hd0) (hd0,msdos6) (hd0,msdos5) (hd0,msdos3) (hd0,msdos1) (hd1) (hd1,msdos5) (hd1,msdos1)

From an fdisk search I found that my boot disk should be /dev/sda1.
 After I have loadede the nfirst part of the Live CD and have gone to the reboot part the computer responds with the following screen;
Hardware Monitor ...
SYS Temp ... etc.
error: no such device : 4264fa64-01dd-4bd5-b43d-5f8dac12ca7f.
grub rescue> _

Should I go for a total meltdown and start all over, or is there a more humane response. At present I have to use the Live CD tryout in order to communicate - a slow and not overly successful method.
HELP anyone got any ideas?
thanks again for the help
rk.

delance (olivier-delance) said : #4

Sorry, the link was changed again!
https://help.ubuntu.com/community/Grub2#Copy_LiveCD_Files

You have to use LiveCD, choose "Try", open a terminal Ctrl+Alt+T and run the commands:
(before check you really have Ubuntu on sda1, with partition table)
sudo mount /dev/sda1 /mnt
sudo grub-install --boot-directory=/mnt/boot /dev/sda
sudo update-grub

rkcarney (rkcarney-uwclub) said : #5

Hi delance
Tried what you said and seemed to be going along sweetly but at the end after I entered the
" sudo update-grub "
got:
" /usr/sbin/grub-probe: error: cannot stat 'aufs' "
 and gave no change.
Any ideas?
rk

delance (olivier-delance) said : #6

We will use another prober: os-probe.
Please follow this link: https://answers.launchpad.net/grub/+faq/1677

rkcarney (rkcarney-uwclub) said : #7

Hi delance,
Afraid no success.
It appears that I already had the os-prober installed and the programme ran alright when I activated it but after the "sudo update-grub"
I got
"/usr/sbin/grub-probe: error: cannot stat 'aufs'. " and reboot put me back to the " grub rescue " command.
Thanks for all the effort, but any further ideas?
rk.

Best delance (olivier-delance) said : #8

I discovered there is a bug created.
In bug thread someone advise to use https://help.ubuntu.com/community/Grub2#METHOD%203%20-%20CHROOT instead of link I provided.

Nobody provided a bulletproof solution, and bug stand since January!
If this method fails, we could have to make manually the grub configuration file.
As error is related to Natty grub configuration, perhaps using an old Ubuntu media CD between 9.10 and 10.10 included, will work, as we will use previous version of bootloader configuration.
I'm afraid finding a workaround will be tedious.

rkcarney (rkcarney-uwclub) said : #9

hi delance,
I think the problem has been solved for me.
I looked at the 'CHroot' method and afraid that's beyond me at the moment ( am only just getting to grips with working in Terminal ). Searching my pile of CDs I found adistro of Natty, 11.04, that I had downloaded straight after upgrading to Natty in April 2011.
I ran a clean install from this LiveCD and got my usual problem of out of range for my screen ( fixed from /etc/default/grub - so all OK). So far working a treat and am now embarking on rebuilding files etc.
Thanks again for all the help, and I still don't understand what happened, though I'm much more of a happy bunny now. Ta,
rk

rkcarney (rkcarney-uwclub) said : #10

Thanks delance, that solved my question.