dual boot not working

Asked by Sherri Oliver on 2011-09-09

My husband installed Ubuntu11.04 or whatever it is, and he made a mistake somewhere. Maybe in the partitioning, I don't know. The issue is, he was supposed to set up for dual boot and it didn't work. I don't know what he did or how, and I need to know how to fix it or remove it. How do I uninstall Ubuntu so I can just get windows back?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Last query:
2011-09-10
Last reply:
2011-09-12

Can you give the output of:

sudo fdisk -l

Thanks

Sherri Oliver (sherrioliver55) said : #2

Please forgive my ignorance, but I have no idea how to use this Ubuntu. Could you tell me how or where or whatever I would do to get that output? Sudo is a command line or something?

mycae (mycae) said : #3

Hello Sherri,

yes, actionparsnip is requesting you enter that in at a comand line. It will generate some output which you can cut and paste back here.

To open a command line (aka terminal) you need to search for the "terminal" application, then run it.

Sherri Oliver (sherrioliver55) said : #4

Thank you. :) I learn quick enough. Here's what I got from it...

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x1549f232

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 30440 244508364+ 7 HPFS/NTFS
/dev/sda2 37441 38913 11831872+ 7 HPFS/NTFS
/dev/sda3 30440 37440 56227841 5 Extended
/dev/sda5 37065 37440 3012608 82 Linux swap / Solaris
/dev/sda6 36690 37065 3005440 82 Linux swap / Solaris
/dev/sda7 30440 36315 47188992 83 Linux
/dev/sda8 36315 36689 3005440 82 Linux swap / Solaris

Partition table entries are not in disk order

Mahmoud El Zahed (mooody-868) said : #5

Could you tell exactly what version of windows is installed? and what is the error message you are getting?

Sherri Oliver (sherrioliver55) said : #6

The computer was bought from a second hand store, it looks like windows Vista was originally installed at the factory, but it had been upgraded to windows 7. When I turn the computer on it does the normal startup thing as far as the "Compaq" screen and then it goes black with an "out of frequency" message, then it goes into a sleep, and I have to wiggle the mouse and Ubuntu lets my enter my pass, and it's like it had already been on and logged in. But logging out of Ubuntu doesn't give me an option to get to Windows either.

peter b (b1pete) said : #7

Sherri,

- from your #4 post it appears that the HD partitions are there ok although there are 3 swap partitions (one would have been sufficient)

- for #4 info - it appears that the win INSTALL files are on sda1 part and that the win is INSTALLED on sda2 (sda1 from win perspective is a hidden part)

- ubuntu uses grub bootloader that is a UNIVERSAL bootloader totally different than win one. so, I would suggest to give it a try and recover win as it is now on the HD; it can be done while you're logged in ubuntu; pls run in a terminal commands (in order shown) as follows

sudo update-grub
sudo grub-install /dev/sda

- pls watch the messages in the terminal while the 2 cmds above run and jot them done just in case
- after the 2 commands finished running pls reboot the pc. if everything is all right you should see the grub menu listing win with its 2 part sda1 and sda2 as well as ubuntu as the first boot option. use arrow keys to select the option desired and press enter.

do you see the grub menu ? if not pls post here the messages when he 2 cmds were run.

Sherri Oliver (sherrioliver55) said : #8

From First command...

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.38-11-generic
Found initrd image: /boot/initrd.img-2.6.38-11-generic
Found linux image: /boot/vmlinuz-2.6.38-8-generic
Found initrd image: /boot/initrd.img-2.6.38-8-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows Vista (loader) on /dev/sda1
done

From second command...

Installation finished. No error reported.

Ok, pasting this info before I restart. hopefully, I'll be right back.

Sherri Oliver (sherrioliver55) said : #9

Nope. Out of curiosity, I switched out my monitor. This one says "frequency out of range, try other resolution"

peter b (b1pete) said : #10

yes - grub is ok PARTIALLY. as far as linux/ubuntu install/side is concerned it is ok. there are problems with win installation apparently.

grub 'saw' sda1 where win INSTALLATION FILES are.

however, there is a problem with sda2 partition where usually win IS INSTALLED - it did not detect the installation as you could see from the update-grub cmd. pls KEEP connected the same monitor that was used for win and ubuntu installations.

the message "frequency out of range, try other resolution" comes from the monitor. see the link below that offers v good advise and explanation as to how this kind of problem can be overcome while logged in ubuntu. use gedit and sudo commands (instead of kate and kdesudo) to edit /etc/default/grub file and sudo if you're not using kubuntu.

http://kubuntuforums.net/forums/index.php?topic=3114781

- a second solution would be as shown on this url

http://www.youtube.com/watch?v=IUXV0um_z3E

maybe one of the two solutions will help.

as far as win is concerned you'll have to talk to the person you purchased the pc from and ask what command and/or how sda1 can be accessed so that win can be REINSTALLED on sda2 (what I'm hearing from people using win it is usually a combination of F keys). ubuntu should never be installed in dual boot mode if win is not operating ok1 - only after win is functioning flawlessly an ubuntu install should be attempted. if you REINSTALL win, grub will be overwritten and ubuntu can not be accessed any longer unless a special procedure is followed.

delance (olivier-delance) said : #11

Follow this FAQ to make sda2 Windows detected:
https://answers.launchpad.net/grub/+faq/1677
If you want Windows to be default boot, follow:
https://answers.launchpad.net/grub/+faq/1676
Don't hesitate to post to get more help.

Peter is right. After, you could remove or merge swap area to have only one.

Can you help with this problem?

Provide an answer of your own, or ask Sherri Oliver for more information if necessary.

To post a message you must log in.