grub does not display activity during boot

Asked by DaleEMoore on 2011-06-07

Prior to Ubuntu 11.04 I could configure grub so that after the menu is displayed and the system is booting detail of the boot activity appears. Now there's just a blank screen between the menu and gdm login.

How do I coax Ubuntu 11.04 to display the boot activity?
Dale E. Moore
Oh yeah; I asked the same question here http://ubuntuforums.org/showthread.php?t=1760753 and they didn't know the answer.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-14
Last reply:
2011-07-03

When you see the black screen, press ESC. Should show the boot messages. You can make the OS ALWAYS show the boot messages by running:

gksudo gedit /etc/default/grub

and change:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to:
GRUB_CMDLINE_LINUX_DEFAULT=""

Save the new file and close gedit, then run:

sudo update-grub

Should be ok

DaleEMoore (daleemoore) said : #2

Hi ActionParsnip; Thanks for your thoughtful reply! My /etc/default/grub is currently:

      GRUB_TIMEOUT=3
      GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

Does that meet your requirements? It certainly does not show the boot messages.

I changed /etc/default/grub to include your suggestion:

      GRUB_CMDLINE_LINUX_DEFAULT=""

then ran update-grub. There was no improvement. Have you tried this yourself on Ubuntu 11.04? I wonder why my system would get different behavior than yours?

I look forward to hearing from you,
Dale

Is that ALL it says, the file is usually much larger...

DaleEMoore (daleemoore) said : #4

Dear ActionParsnip;

These 3 lines are all there is:

      GRUB_TIMEOUT=3
      GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
      GRUB_CMDLINE_LINUX_DEFAULT=""

Do you have a sample of an Ubuntu 11.04 /etc/default/grub that displays the boot activity detail between grub menu and gdm login? I'd just love it if you would pass that on to me.

Thanks for your time,
Dale

delance (olivier-delance) said : #5

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

DaleEMoore (daleemoore) said : #6

Dear Delance;

Thank you very much for spending your time to try to help me with this bug in Ubuntu. Sadly your suggestion was of no help at all. There is still no display between the grub menu and gdm login. Would you send me your Ubuntu 11.04 /etc/default/grub that does give activity display between the grub menu and gdm login?

I look forward to hearing from you,
Dale

delance (olivier-delance) said : #7

Sorry, I provided the file from wrong Virtual Machine.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I get shutdown text, then at restart a pink screen, and display after 4s. of start, and finally desktop (I don't use gdm).

DaleEMoore (daleemoore) said : #8

Dear Delance;

It sounds like you're telling me this /etc/default/grub also does not display the boot activity after your grub menu. But, I can't tell from your note if that's what you are saying or not; so I'll give it a try....

Moore later,
Dale

DaleEMoore (daleemoore) said : #9

Still nothing Delance; I sure wish there were a way to see what's going on like I could before Ubuntu 11.04.

DaleEMoore (daleemoore) said : #10

nudge

delance (olivier-delance) said : #11

Press <ESC> as soon you see purple screen. In this case, Grub must display all boot printing. If not, issue is more probably in the kernel. In this last case, set nomodeset at boot and see if it solves issue.

DaleEMoore (daleemoore) said : #12

Hi Delance;

<ESC> after grub menu has no obvious effect.

nomodeset displays a few more lines in the [OK] [fail] summary but does not display boot activity. Also, there are resolution problems later.

Nothing seems to turn back on the boot activity display,
Dale

delance (olivier-delance) said : #13

What are the lines you are expecting in what you call "boot activity" ? I'm not sure on which boot/init phase you have issues. Are they before or after "[OK] [fail] summary" ?

DaleEMoore (daleemoore) said : #14

Hi Delance; Thanks for this opportunity to explain! I've got about 30 machines running Ubuntu 11.04. They got to 11.04 via different paths; some were "do-release-upgrade -d"ed; others installed from Ubuntu Desktop CD. And they all exhibit the same no-boot-detail-display behavior. Sadly, I have no previous versions of Ubuntu (that I know of) to compare to so I'll be relying on my enfeebled memory to describe reality.

In prior releases of Ubuntu, before 11.04; I saw the activity of booting while it was happening. I always changed the grub config so that I could watch, and learn what was happening and could sometimes diagnose issues arising. But, with 11.04 I can't see what's going on... I just see a blank screen after the grub menu, then a quick "[OK] [fail]" summary (which is impossible for me to discern the [fail]ed items,) then the gdm login, then another several seconds of blank-ness while X gets going. So of the entire boot time, the majority of it is blank-ness; instead of informative messages of what's going on.

I'm focusing on the blank-ness between the grub menu and the gdm login; and, hoping that I can get back to the pre-11.04 activity detail display.

I want to get back to the informativeness,
Dale
PS: I hope this wasn't too vague as to be useless!

DaleEMoore (daleemoore) said : #15

nudge

DaleEMoore (daleemoore) said : #16

wink

Launchpad Janitor (janitor) said : #17

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

elviseftv (elviseftv) said : #18

This post also treats about this "issue": http://utcc.utoronto.ca/~cks/space/blog/linux/Ubuntu1204VerboseBoot, but as You can see with no results though. I want these boot messages appear too. Even when I press ESC key, nothing changes. But I want to have it visible without any key press need. I'm just wondering why is that.. no boot messages and no option to show it in ubuntu 12.04.

DaleEMoore (daleemoore) said : #19

Hi elvis_ef (jarmar85); Yes, I find it wretchedly frustrating that Ubuntu is moving to Windows-dumbed-down pablum. I wear big boy pants, I can handle it. Allow me the option of turning on a technical visual display of what's happening during boot. My experience is that this technical display comes in handy when diagnosing hardware problems.

elviseftv (elviseftv) said : #20

Yes, You're right. I found something that I tested out. I can't find out if this is a full output of all boot messages, but You can find it out: http://www.kernel.org/doc/Documentation/kernel-parameters.txt - focus on the parameters: "debug", "debug_locks_verbose", "debug_objects" and "debugpat" (they can be passed for example through the "grub.cfg" file). It all seems to treat about debugging. I followed some forums advices without any sufficient help - reason: no good answer. But these kernel command information may be sufficient. But I feel there is still not full boot activity info. Can You check that somehow?

No "splash" or "quiet" option clearing helps, this we know yet. There is another kernel command called "priority", take a look at it if You want, but I don't see the difference, as the boot messages are vanishing too fast. I don't know why ubuntu programmers don't want us to see anything just directly from the boot screen (and not digging in all the files, searching for anything). I read on some forums, that ubuntu 9.04 or 10.04 needed only removing "quiet" and "splash" to make this work. I tried even removing plymouth themes, hoping that helps a lot, but I couldn't because I have my gnome-desktop package installed (with all spoftware and so on, can't remember how is this called... hmm.. metapackage?). So I can't even check if that helps too.

DaleEMoore (daleemoore) said : #21

Earlier Ubuntus could be configured to be more helpful and verbose; but, sadly those people must have died off. Thanks for the note about kernel configuration. I may find time to look into that in a few months.

DaleEMoore (daleemoore) said : #22

Perhaps this forum http://askubuntu.com/questions/199302/grub-does-not-display-activity-during-boot will provide some useful information.

elviseftv (elviseftv) said : #23

Of course, take Your time. Anyway I've recently discovered too (a bit eralier but wasn't sure), this thing about "gfxpayload", that something is wrong with it and now You pasted a link to a post with such problem. So this is another cause of troubles with showing boot activity. I'm wondering now how can I change my console resolution (not grub menu) now? (gfxpayload won't do that - it will just hide everything). Only VGA parameter could do that but as ubuntu says it's now "depreciated".

elviseftv (elviseftv) said : #24

Just to mention something, I've just successfulyl downgraded from Grub2 (1.99) to Grub 0.97 (now called Legacy) and the all info showing (after removing just "quiet" and "splash") options seems to be sufficient (lots of information) and like in Grub2 (after adding extra "debug" option). So.. have no idea but I think it could be the answer, just in Grub2 add "debug" option as a loading kernel parameter.

DaleEMoore (daleemoore) said : #25

Andrea Corbellini has some very good suggestions here
http://askubuntu.com/questions/199302/grub-does-not-display-activity-during-boot.

elviseftv (elviseftv) said : #26

Yes I know, You suggested that in a previous posts but I tested it, and it doesn't work for me. GFXPAYLOAD is making problem everytime I try to change console resolution (blank screen after choosing grub menu option and before login screen) to a higher one. So neither "grub.cfg" file change nor "/etc/default/grub.d" files make difference. But maybe this is just an issue on my laptop..

Can you help with this problem?

Provide an answer of your own, or ask DaleEMoore for more information if necessary.

To post a message you must log in.