GRUB doesn't recognize an external keyboard

Asked by Ignasi on 2011-05-17

I've a Toshiba Tecra A8 with a docking station. I plug the laptop to docking station and use external monitor, keyboard and mouse without opening the laptop. I've ubuntu and windows installed on it a select which starts with GRUB. I've been using both without any problem with several ubuntu versions. After last update to ubuntu 11.04 grub doesn't recognize my external keyboard until the system starts so I cannot select the operating system. I can open the laptop and use laptop's keyboard but it's not so comfortable. I've reverted to ubuntu 10.04 (LTS) because it was working but now the problem persists. Until installing 11.04 I didn't realized about new grub version (no menu.lst). Ubuntu 10.10 was still using menu.lst. Now 10.04 is configured through /etc/default/grub.
Could you help me?

Thank you,

Ignasi

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Last query:
2013-02-28
Last reply:
2011-07-27
delance (olivier-delance) said : #1

Check in BIOS parameter of USB keyboard/mouse is legacy or not.

Ignasi (nignasi) said : #2

The BIOS says:

Peripheral

LEGACY EMULATION
USB KB/Mouse Legacy Emulation = Enabled
USB-FDD Legacy Emulation = Enabled
USB Memory BIOS Support Type = HDD

Ignasi (nignasi) said : #3

Sorry! I pressed somewhere which marked the problem as solved. It's not solved.

My complete comment is:

Some information from the BIOS:

Device config = Setup by OS

------
PERIPHERAL
 Internal Pointing Device = Enabled
 Ext Keyboard "Fn" = Disabled
 Parallel Port Mode = ECP
----
LEGACY EMULATION
 USB KB/Mouse Legacy Emulation = Enabled
 USB-FDD Legacy Emulation = Enabled
 USB Memory BIOS Support Type = HDD

delance (olivier-delance) said : #4

Looks OK. Please open a bug. You will find next text edition area a button named "Create a bug report".

Are the arrow keys you are trying to use, to navigate up and down in the list, on the numeric keypad? If they are, have you made sure Number Lock is off?

Ignasi (nignasi) said : #6

No. I use a wireless keyboard from Microsoft. It has three groups of keys. The alphanumerical one, the numeric keypad and a third gorup with arrows and page up/down keys.

If you use a wired USB keyboard, does the problem still occur?

Ignasi (nignasi) said : #8

No. I've tried with a wired USB keyboard from another computer and worked. I can move through boot menu with arrow keys. I've updated my bug report (786857) with this information.

With the wireless keyboard, are you able to make the Number Lock, Caps Lock, and Scroll Lock lights turn on and off, while you are in the boot menu?

Does the wireless keyboard work on another computer?

delance (olivier-delance) said : #10

I used also a Microsoft keyboard: Wireless Keyboard 1000. Which model do you use ?

Ignasi (nignasi) said : #11

My keyboard is CE0560. Its connection to port replicator is PS2. It also had a wireless mouse but It broke some time ago and now I use a USB wireless mouse.

Both keyboard and mouse work without any problem once the system has started. The problem appears just during selection of booting proces. The external display shows operating system's list but the external keyboard doesn't allow to select them.

For Eliah: Lights behaviour:
1-After switching on Numer Lock is on and Caps and Scroll Lock off.
2-While boot menu is on display they don't change even I press repective keys.
3-Once default option (or selected option through laptop keyboard) starts to load, three lights switch off for a while.
4-Once system is loaded everything works.

I've been working with this computer, port replicator, mouse, keyboard and display for a couple of years without any problem. Always with windows XP and several Ubuntu versions. There have been no problem until last update from ubuntu 10.10 to 11.04 but it remains after a fresh install of ubuntu 10.04.

cosmin (wizardelo) said : #12

i have a similar problem :

i have 11.04 Ubuntu x64 distribution kernel 2.3.38-11 along with Windows 7 on a Toshiba Sat655 Laptop
problem is when i first open my laptop keyboard wont work in grub menu, i cant do anything until the 10s go out and it loads default OS. after it boots up in the first choise keyboard functionality returns, nomatter what they first choice was set (linux/win)
the odd fact that i found is that, if i power laptop down while in grub menu, and then power it up right away, keyboard works in grub also,
after a normal reboot, keyboard fails to work again.

i doubt its a bios thing because if i power down and power up laptop there is no bios changes.
i will try with "GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nopnp=1 i8042.dumbkbd=1" in /boot/default/grub
and see if its a solution

delance (olivier-delance) said : #13

Check in BIOS USB keyboard legacy, even if you think issue is outside BIOS.

darkonc (samuel-bcgreen) said : #14

in /boot/grub/custom.cfg , add:

  insmod usb
  insmod ehci
  insmod uhci
  insmod ohci
  insmod usb_keyboard.mod

See if that makes a difference.

Ignasi (nignasi) said : #15

darkonc,

no difference. Now I've updated to ubuntu 12.04. There is no custom.cgf under /boot/grub, so I created it and wrote there what you proposed. The result was a new GRUB menu with some characters after last item (windows), but no effect on activating usb wireless keyboard.

Can you help with this problem?

Provide an answer of your own, or ask Ignasi for more information if necessary.

To post a message you must log in.