[X] maverick32/grub2 5ubuntu4 alternate install failure/s.

Asked by peter b on 2010-10-21

4 install attempts on WD usb HD connected to eeePC1000 with 2 ssd internal drives have failed.

the install partitioner id's the 2 ssd as sda and sdb while WD is sdc. maverick installed on sdc10 (created and configured with the partitioner w bootable flag OFF); there is also lucid and karmic installed on sdcy and sdcz - both boot/work flawless; grub2 1ubuntu7 installed to sda.

during maverick install AT grub install stage in spite of the fact that all other os's identified AND, specifically pointed out that it is SAFE to install grub2 MBR, after Yes button pressed the next screen (with the progress bar displayed), surprise, displayed installing grub to /dev/sdc !!. at first boot after install instead of grub menu a v terse mssge ... error : no such device UUIDzxzxzxzxzx followed by grub-rescue> . entering ls at prompt - total disappointment - the output of ls (hdx,msdosy) displays unknown filesystem etc. this was first attempt.

second attempt, at grub install stage instead of Yes button (install to MBR, see above that failed) No button used and manually entered /dev/sda. result - same as above.

attempts 3 an 4 done with Mint julia RC ; results - same as 1 and 2.

any help ? am I missing anything or doing wrong ? the mess that these installed attempts left behind on the v good, reliable working releases is,.... well... something for another time to discuss.

Question information

English Edit question
Ubuntu grub2 Edit question
No assignee Edit question
Solved by:
peter b
Last query:
Last reply:
Revision history for this message
peter b (b1pete) said :

recovery after above failure/s ,

I managed to recover - log in lucid (grub 198 1ubuntu7 rel); as mentioned, mint julia was the last attempt to install maverick.

trying to recover grub while logged in lucid,

update-grub 'HAS SEEN' julia mint and created the necessary menuentry in grub.cfg. besides the other ubuntu releases already installed. I must point out that that was not the case with the ubuntu maverick - error:mssge and grub-rescue> was all the time displayed after attempts to recover grub in lucid.

after grub-install /dev/sda run in lucid the system was fully recovered but .... bootable by lucid grub 198 1ubuntu7 rel. obviously.

having in mind the install experiences (failed grub runs see above) I not dare run install grub2 while logged in julia (grub 198 5ubuntu3 rel) - I might get the system in a bigger mess and a v iffy recovery.

Revision history for this message
peter b (b1pete) said :

sorry, typo in the title

....'5ubuntu4'.... should read ....'5ubuntu3'....

Revision history for this message
delance (olivier-delance) said :

Your issue looks a little complicated.
You could have a look at:
to see how to install again Grub2, which solves lot of issues after a failed Ubuntu installed (but not all issues).
Could you provide the partition tables of the three disks, with contents of each one (Maverick, Mint, ...).

Revision history for this message
peter b (b1pete) said :

yes, I'm fully aware (for quite a bit of time I might say) of the contents of the url you've indicated; - the pc was in perfect working order for months on end and was booting without any flaw with lucid grub 198 1ubuntu7 before the attempts made to install maverick/julia. I must also add that in this user's case grub backups are always made immediately a new os is successfully installed, - the aborted installation is always cleaned up.

however, as mentioned, this question pertains to maverick/julia installs on logical partitions AND grub install

- the problem (encountered and described) is while maverick and mint alternate 32 ver CD were used (to install them);

- the alternate CD partitioner on manual mode identifies the drives sda, sdb and sdc in the same order as they are entered in the BIOS - the first 2 ssd's and the third, WD HD usb connected;

- the install procedure completed with no problems UP to install grub stage; the first screen under this sub routine displayed ....'that all other os's ...... identified AND, specifically pointed out that it is SAFE to install grub2 to MBR'... with the two buttons <Yes> and <No>.

- when the option <Yes> was selected the screen immediately following under the progress bar displayed .... /dev/sdc ; now, /dev/sdc in my understanding is not the pri drive that contains the MBR - it is always /dev/sda; it contained a v good solid MBR that I had an image of and used in the recovery procedure

- at first boot after, there were 3 error lines that I did not write down (one of them was that the UUIDxsxczv... was not recognized) and the 4th grub-rescue> . I'm v conversant with grub-rescue procedure and tried ls cmd - the number of partitions presented DID NOT even come close to the ones identified by the install partitioner number; the recovery under these circumstances was not possible obviously.

- deleted with gparted live CD the partition created with the install partitioner and repeated the install procedure this time using the <No> option selected AND /dev/sda manually entered at the next screen; result/outcome - same as described when <Yes> grub install option used.

- same happened with julia rel EXCEPT that this time the install partition was NOT deleted AND lucid MBR image described above was used and MBR restored. after update-grub ran under lucid, julia release install was 'seen' by grub 198 1ubuntu7 and reinstall grub to /dev/sda succeeded. I have now a perfectly good system but booting under grub 198 1ubuntu7. the ls cmd under grub> works flawless.

here below is copy/excerpt of Mint julia entry in grub.cfg created by update-grub under lucid

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Linux Mint 10, 2.6.35-22-generic (/dev/sdd10) (on /dev/sdc10)" {
 insmod ext2
 set root='(hd2,10)'

it is self explanatory

so, besides the fact that I'm not at liberty to submit any info re this pc without permission, I do not see what new light the ALL partition info may shed into this v specific problem - the maverick32 install procedure present on the alternate CD.

if you see that I miss or did anything wrong during the install procedure , by all means pls let me know. tu.